aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/txdrug/txdrug_0.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/txdrug/txdrug_0.1.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/txdrug/txdrug_0.1.bb')
-rw-r--r--recipes-qtopia/txdrug/txdrug_0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qtopia/txdrug/txdrug_0.1.bb b/recipes-qtopia/txdrug/txdrug_0.1.bb
new file mode 100644
index 0000000..baa9f52
--- /dev/null
+++ b/recipes-qtopia/txdrug/txdrug_0.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Tx Drug Database"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "sqlite"
+PR = "r3"
+
+SRC_URI = "http://teax.sourceforge.net/txdrug-${PV}.tar.gz \
+ file://opt/QtPalmtop"
+S = "${WORKDIR}/txdrug-tar"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += "LIBS+=-lsqlite TARGET=txdrug"
+
+do_configure_prepend() {
+ rm -f Makefile && qmake -project
+}
+
+do_configure_append() {
+ sed -i "s/\-I\/usr\/include\/sqlite\ //g" Makefile
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}
+ cp -Pfr `ls -dp ${WORKDIR}/opt/QtPalmtop/*|grep -v SCCS` ${D}${palmtopdir}/
+ install -D -m 755 txdrug ${D}${palmtopdir}/bin/txdrug
+}
+
+
+SRC_URI[md5sum] = "c867374392559d6e475eeb03f6a81169"
+SRC_URI[sha256sum] = "ee1044b61fc457ecc6025d06c5b9241994bd19e3d6ce98ae0827842caab00f0f"