aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/uqm/uqm_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/uqm/uqm_0.5.0.bb')
-rw-r--r--recipes-qtopia/uqm/uqm_0.5.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qtopia/uqm/uqm_0.5.0.bb b/recipes-qtopia/uqm/uqm_0.5.0.bb
new file mode 100644
index 0000000..ad315ea
--- /dev/null
+++ b/recipes-qtopia/uqm/uqm_0.5.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Star Control 2 source port using SDL (see sc2.sourceforge.net)"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-net libvorbis libogg zlib"
+SECTION = "games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r2"
+
+S = "${WORKDIR}/uqm-${PV}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sc2/uqm-${PV}-source.tar.gz \
+ file://build-opts.sh \
+ file://build-oe.patch;striplevel=0 \
+"
+
+do_configure() {
+ install ${WORKDIR}/build-opts.sh ${S}/
+ ./build-opts.sh ${STAGING_DIR_HOST}${layout_prefix} ${STAGING_BINDIR} ${STAGING_LIBDIR}
+}
+
+do_compile() {
+ export ARCH="${TARGET_ARCH}"
+ export CC="${CC}"
+ export STAGING_INCDIR="${STAGING_INCDIR}"
+ export STAGING_LIBDIR="${STAGING_LIBDIR}"
+ ./build.sh uqm
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 uqm ${D}${bindir}
+}
+
+SRC_URI[md5sum] = "9002b1bc2de9285588dd97b618a867a7"
+SRC_URI[sha256sum] = "bdb715784bf0c94825cf40f97c60a5ec83fd3e17e9e186a78cd145781c4d9804"