aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/visiscript
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/visiscript')
-rw-r--r--recipes-qtopia/visiscript/files/qcleanuphandler.h127
-rw-r--r--recipes-qtopia/visiscript/files/qptrlist.h9
-rw-r--r--recipes-qtopia/visiscript/visiscript_0.3.2.bb36
-rw-r--r--recipes-qtopia/visiscript/visiscript_0.4.3.bb38
4 files changed, 210 insertions, 0 deletions
diff --git a/recipes-qtopia/visiscript/files/qcleanuphandler.h b/recipes-qtopia/visiscript/files/qcleanuphandler.h
new file mode 100644
index 0000000..90f65b0
--- /dev/null
+++ b/recipes-qtopia/visiscript/files/qcleanuphandler.h
@@ -0,0 +1,127 @@
+/****************************************************************************
+** $Id: qt/qcleanuphandler.h 3.3.3 edited May 27 2003 $
+**
+** ...
+**
+** Copyright (C) 2001-2002 Trolltech AS. All rights reserved.
+**
+** This file is part of the tools module of the Qt GUI Toolkit.
+**
+** This file may be distributed under the terms of the Q Public License
+** as defined by Trolltech AS of Norway and appearing in the file
+** LICENSE.QPL included in the packaging of this file.
+**
+** This file may be distributed and/or modified under the terms of the
+** GNU General Public License version 2 as published by the Free Software
+** Foundation and appearing in the file LICENSE.GPL included in the
+** packaging of this file.
+**
+** Licensees holding valid Qt Enterprise Edition or Qt Professional Edition
+** licenses may use this file in accordance with the Qt Commercial License
+** Agreement provided with the Software.
+**
+** This file is provided AS IS with NO WARRANTY OF ANY KIND, INCLUDING THE
+** WARRANTY OF DESIGN, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
+**
+** See http://www.trolltech.com/pricing.html or email sales@trolltech.com for
+** information about Qt Commercial License Agreements.
+** See http://www.trolltech.com/qpl/ for QPL licensing information.
+** See http://www.trolltech.com/gpl/ for GPL licensing information.
+**
+** Contact info@trolltech.com if any conditions of this licensing are
+** not clear to you.
+**
+**********************************************************************/
+
+#ifndef QCLEANUPHANDLER_H
+#define QCLEANUPHANDLER_H
+
+#ifndef QT_H
+#include "qptrlist.h"
+#endif // QT_H
+
+template<class Type>
+class QCleanupHandler
+{
+public:
+ QCleanupHandler() : cleanupObjects( 0 ) {}
+ ~QCleanupHandler() { clear(); }
+
+ Type* add( Type **object ) {
+ if ( !cleanupObjects )
+ cleanupObjects = new QPtrList<Type*>;
+ cleanupObjects->insert( 0, object );
+ return *object;
+ }
+
+ void remove( Type **object ) {
+ if ( !cleanupObjects )
+ return;
+ if ( cleanupObjects->findRef( object ) >= 0 )
+ (void) cleanupObjects->take();
+ }
+
+ bool isEmpty() const {
+ return cleanupObjects ? cleanupObjects->isEmpty() : TRUE;
+ }
+
+ void clear() {
+ if ( !cleanupObjects )
+ return;
+ QPtrListIterator<Type*> it( *cleanupObjects );
+ Type **object;
+ while ( ( object = it.current() ) ) {
+ delete *object;
+ *object = 0;
+ cleanupObjects->remove( object );
+ }
+ delete cleanupObjects;
+ cleanupObjects = 0;
+ }
+
+private:
+ QPtrList<Type*> *cleanupObjects;
+};
+
+template<class Type>
+class QSingleCleanupHandler
+{
+public:
+ QSingleCleanupHandler() : object( 0 ) {}
+ ~QSingleCleanupHandler() {
+ if ( object ) {
+ delete *object;
+ *object = 0;
+ }
+ }
+ Type* set( Type **o ) {
+ object = o;
+ return *object;
+ }
+ void reset() { object = 0; }
+private:
+ Type **object;
+};
+
+template<class Type>
+class QSharedCleanupHandler
+{
+public:
+ QSharedCleanupHandler() : object( 0 ) {}
+ ~QSharedCleanupHandler() {
+ if ( object ) {
+ if ( (*object)->deref() )
+ delete *object;
+ *object = 0;
+ }
+ }
+ Type* set( Type **o ) {
+ object = o;
+ return *object;
+ }
+ void reset() { object = 0; }
+private:
+ Type **object;
+};
+
+#endif //QCLEANUPHANDLER_H
diff --git a/recipes-qtopia/visiscript/files/qptrlist.h b/recipes-qtopia/visiscript/files/qptrlist.h
new file mode 100644
index 0000000..9a07e1e
--- /dev/null
+++ b/recipes-qtopia/visiscript/files/qptrlist.h
@@ -0,0 +1,9 @@
+#ifndef QTCOMPAT_QPTRLIST_H
+#define QTCOMPAT_QPTRLIST_H
+
+#include <qlist.h>
+
+#define QPtrList QList
+#define QPtrListIterator QListIterator
+
+#endif
diff --git a/recipes-qtopia/visiscript/visiscript_0.3.2.bb b/recipes-qtopia/visiscript/visiscript_0.3.2.bb
new file mode 100644
index 0000000..17a661e
--- /dev/null
+++ b/recipes-qtopia/visiscript/visiscript_0.3.2.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "VisiScript is a simple graphical frontend for \
+scripting languages like minscript, Python,Ruby, Perl or others. \
+VisiScript runs on the Qtopia desktop environment of the Zaurus."
+SECTION = "opie/applications"
+DEPENDS = "qscintilla"
+LICENSE = "GPL"
+PR = "r1"
+
+APPNAME = "visiscript"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
+ file://qptrlist.h file://qcleanuphandler.h"
+S = "${WORKDIR}/visiscript-${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "zvisiscript.pro"
+
+EXTRA_QMAKEVARS_POST += "LIBS-=../qscintilla-1.60-gpl-1.3/qt/lib/libqscintilla_arm.a LIBS+=-lqscintilla"
+export OE_QMAKE_LINK="${CXX}"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/*.h ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
+}
+
+#FIXME: package help and translation
+
+SRC_URI[md5sum] = "c43beaef5817fe525099341620e3584b"
+SRC_URI[sha256sum] = "3ec61d179aa29811f1383bd99c529342aecea1b3b4cffaa8670aecd7486d0c94"
diff --git a/recipes-qtopia/visiscript/visiscript_0.4.3.bb b/recipes-qtopia/visiscript/visiscript_0.4.3.bb
new file mode 100644
index 0000000..6d5b331
--- /dev/null
+++ b/recipes-qtopia/visiscript/visiscript_0.4.3.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "VisiScript is a simple graphical frontend for \
+scripting languages like minscript, Python,Ruby, Perl or others. \
+VisiScript runs on the Qtopia desktop environment of the Zaurus."
+SECTION = "opie/applications"
+DEPENDS = "qscintilla"
+LICENSE = "GPL"
+APPNAME = "visiscript"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+BROKEN = "1"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
+ file://qptrlist.h file://qcleanuphandler.h"
+
+S = "${WORKDIR}/visiscript-${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "zvisiscript.pro"
+PARALLEL_MAKE = ""
+
+EXTRA_QMAKEVARS_POST += "LIBS-=../qscintilla-1.65-gpl-1.6/qt/libqscintilla.a LIBS+=-lqscintilla LIBS+=-ldl"
+export OE_QMAKE_LINK="${CXX}"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/*.h ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
+}
+
+#FIXME: package help and translation
+
+SRC_URI[md5sum] = "f625eb9cffa82e35c3c477c58aa98795"
+SRC_URI[sha256sum] = "39f2dfd8aaf41b51aadaa06c862b75d82c8f0ffd268d03d37e5895c038366271"