aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-06-21 11:20:24 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-23 14:23:38 +0100
commit1ee07350eac47f389d6ef769c054d0ab2c258dd4 (patch)
tree808e2dc747cfdfafe00c46e9ac2948e1b39cefe5
parentecb1fa6ed2366a031ba374d16d4ccbbd8b7fc7e6 (diff)
downloadopenembedded-core-contrib-1ee07350eac47f389d6ef769c054d0ab2c258dd4.tar.gz
linux-yocto/4.1: SPI, MFD, alsa and perf backports
Backporting the following mainline support for enhanced/improved support on BXT based platforms. spi: pxa2xx: Fix too early chipselect deassert spi: pxa2xx: Update comment in int_transfer_complete() spi: pxa2xx: Print actual DMA/PIO transfer mode in debug messages spi: atmel: remove warning when !CONFIG_PM_SLEEP spi: fix kernel-doc warnings in spi.h spi: expose spi_master and spi_device statistics via sysfs spi: meson: Fix module autoload for OF platform driver spi: bcm2835: BUG: fix wrong use of PAGE_MASK spi: bcm2835: fix overflow in calculation of transfer time spi: bcm2835: bcm2835_dma_release() can be static spi: bcm2835: fix kbuild compile warnings/errors and a typo spi: bcm2835: enable dma modes for transfers meeting certain conditions spi: bcm2835: fallback to interrupt for polling timeouts exceeding 2 jiffies spi: spi-pxa2xx: Remove unused legacy null dma buffer and allocation for it mfd: intel-lpss: Save register context on suspend mfd: intel-lpss: Pass I2C configuration via properties on BXT perf/x86: Fix time_shift in perf_event_mmap_page perf/x86: Improve accuracy of perf/sched clock ALSA: hda - Move send_cmd / get_response to hdac_bus_ops ALSA: hda - Merge codec and controller helpers ALSA: hda - moved alloc/free stream pages function to controller library ALSA: hda - Add DSP loader to core library code ALSA: hda - Add the controller helper codes to hda-core module ALSA: hda - Handle error from get_response bus ops directly Revert "ALSA: hda - fix number of devices query on hotplug" Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 456ae80e85..034a869890 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "8fd10e4d4113e72bf46e5bc9eb15c8ccf32bc15a"
+SRCREV_machine ?= "774b26df9e2ddce26e1ead27b6925b2d260919dd"
SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 77da5de8ad..d34a6d7bbc 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.26"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "e634eecdb20b865f5b3d94e2006832c3e6e85358"
+SRCREV_machine ?= "994588340bf1d2d357f86fceec0e3239126b12ee"
SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index 0ab26e63a8..9a31ddce25 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "4f0e75ff79949f2924a5103079ce1fc5e0a1d244"
-SRCREV_machine_qemuarm64 ?= "e634eecdb20b865f5b3d94e2006832c3e6e85358"
-SRCREV_machine_qemumips ?= "332b2b5ef3de2ec31ff8d7687ff7b60892c2b052"
-SRCREV_machine_qemuppc ?= "e634eecdb20b865f5b3d94e2006832c3e6e85358"
-SRCREV_machine_qemux86 ?= "e634eecdb20b865f5b3d94e2006832c3e6e85358"
-SRCREV_machine_qemux86-64 ?= "e634eecdb20b865f5b3d94e2006832c3e6e85358"
-SRCREV_machine_qemumips64 ?= "5133c3b201f3cee041b0911928672d2f1a2c8c9a"
-SRCREV_machine ?= "e634eecdb20b865f5b3d94e2006832c3e6e85358"
+SRCREV_machine_qemuarm ?= "9fc1d1bc96fc8483abacb38d3a6bdd64163494ac"
+SRCREV_machine_qemuarm64 ?= "994588340bf1d2d357f86fceec0e3239126b12ee"
+SRCREV_machine_qemumips ?= "5117bb86942f16f5d6d1303350e0d3522bcc9c43"
+SRCREV_machine_qemuppc ?= "994588340bf1d2d357f86fceec0e3239126b12ee"
+SRCREV_machine_qemux86 ?= "994588340bf1d2d357f86fceec0e3239126b12ee"
+SRCREV_machine_qemux86-64 ?= "994588340bf1d2d357f86fceec0e3239126b12ee"
+SRCREV_machine_qemumips64 ?= "d6904084bddb0cce44f29e0a6c6202a2f0b41671"
+SRCREV_machine ?= "994588340bf1d2d357f86fceec0e3239126b12ee"
SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \