aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-05-21 03:45:03 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-06-16 18:24:04 +0800
commita05167c5bf0877dc40887e9040f3f386bf4b1263 (patch)
tree28cdd67e681c06d01d0a51ec12c6e1a0195b5c76
parent12bab2d828836c8926f753caff80b61dbe6390a5 (diff)
downloadopenembedded-core-contrib-a05167c5bf0877dc40887e9040f3f386bf4b1263.tar.gz
initramfs-image-minimal.bb: add recipe
Add a recipe for a minimal initramfs image. Note that the purpose of this recipe is totally different from that of core-image-minimal-initramfs.bb. The latter is supposed to be used in the live image to "boot" or "install". The former is more like a traditional initramfs whose responsibility is to deal with the kernel parameters and then bring up the real root file system. After adding this recipe, we could specify INITRAMFS_IMAGE to be "initramfs-image-minimal". Note that in OE, we didn't have a reference image recipe for INITRAMFS_IMAGE. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/images/initramfs-image-minimal.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-core/images/initramfs-image-minimal.bb b/meta/recipes-core/images/initramfs-image-minimal.bb
new file mode 100644
index 0000000000..24501e0446
--- /dev/null
+++ b/meta/recipes-core/images/initramfs-image-minimal.bb
@@ -0,0 +1,19 @@
+# Minimal initramfs image
+DESCRIPTION = "Minimal initramfs image used to bring up the system."
+LICENSE = "MIT"
+
+PACKAGE_INSTALL = "initramfs-framework-base initramfs-module-udev busybox udev base-passwd"
+
+# Do not pollute the initramfs image with rootfs features
+IMAGE_FEATURES = ""
+IMAGE_LINGUAS = ""
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit image
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
+
+# We need to set USE_DEVFS to "0" here to trigger creation of device nodes at rootfs time.
+# The reason here is that, when this initramfs is bundled into kernel, we need /dev/console
+# to be there before init is run.
+USE_DEVFS = "0"