aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2016-09-21 15:12:43 +0530
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-22 11:08:22 +0100
commit9470e0911838a6f5a23f01c6944906b69aa1317a (patch)
treeccfe0f8e6c8da7d24311f0672f645ece3ac77846
parente2289647ace9ef96e6a7e4aae201fd9149e56678 (diff)
downloadopenembedded-core-contrib-9470e0911838a6f5a23f01c6944906b69aa1317a.tar.gz
x264: add textrel to INSANE_SKIP
Tried by adding CFLAGS_append = " -fpic " to the recipe. But that couldn't help resolve the warning message: x264/r2491+gitAUTOINC+c8a773ebfc-r0/packages-split/x264/usr/lib/libx264.so.144' has relocations in .text [textrel] It was found that this warning is emitted because of the assembly files in the source code. And it is not easy to get rid of TEXTREL's which are coming from the assembly source files. Adding textrel to INSANE_SKIP resolves this issue. This issue was observed in cyclone5 and imx6qsabresd BSP's. So generalizing the patch. Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-multimedia/x264/x264_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb
index fa44f9c03f..393310f684 100644
--- a/meta/recipes-multimedia/x264/x264_git.bb
+++ b/meta/recipes-multimedia/x264/x264_git.bb
@@ -48,6 +48,6 @@ do_install() {
oe_runmake install DESTDIR=${D}
}
-# PIC can't be enabled for 32-bit x86
-INSANE_SKIP_${PN}_append_x86 = " textrel"
+# PIC can't be enabled for few BSP's
+INSANE_SKIP_${PN}_append = " textrel"