aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-04-24 14:05:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-24 11:09:19 +0100
commit8f905077aaed3dbeeed04787add1cf725fa87bdc (patch)
tree2b1eca30a5e6adb916626a80d41c9af0598e1af0
parent33af68d62bb427c588f5eeecb75fbc31b55f8459 (diff)
downloadopenembedded-core-contrib-8f905077aaed3dbeeed04787add1cf725fa87bdc.tar.gz
uninative-tarball: delete the packagedata task
This task is meaningless for uninative-tarball as the package task has been deleted. Besides, sometimes it would cause problems. To reproduce, use the following command. bitbake uninative-tarball -c cleansstate && bitbake uninative-tarball && bitbake uninative-tarball -c clean && bitbake uninative-tarball The error is something like below. File: 'sstate.bbclass', lineno: 33, function: sstate_installpkg 0029: bb.build.exec_func(f, d) 0030: 0031: for state in ss['dirs']: 0032: prepdir(state[1]) *** 0033: os.rename(sstateinst + state[0], state[1]) 0034: sstate_install(ss, d) 0035: 0036: for plain in ss['plaindirs']: 0037: workdir = d.getVar('WORKDIR', True) Exception: OSError: [Errno 2] No such file or directory [YOCTO #7597] Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
index 62bdde85fc..41f7927e19 100644
--- a/meta/recipes-core/meta/uninative-tarball.bb
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -23,6 +23,7 @@ inherit populate_sdk
deltask install
deltask package
+deltask packagedata
SDK_DEPENDS += "patchelf-native"