aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2015-03-20 18:07:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-06 20:36:02 +0100
commitae3d6524f27cc7efad62e7ca3f4a95942a725b28 (patch)
treec13e68f5e0b9a805fa8451a3558658163823696b
parent664d8d9c8aea941995d62f052a868b602491083b (diff)
downloadopenembedded-core-contrib-ae3d6524f27cc7efad62e7ca3f4a95942a725b28.tar.gz
stress: add new package
Deliberately simple workload generator for POSIX systems. It imposes a configurable amount of CPU, memory, I/O, and disk stress on the system. Moving the package from meta-linaro as a dependency for rt-tests ptest Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/stress/files/texinfo.patch79
-rw-r--r--meta/recipes-extended/stress/stress_1.0.4.bb14
2 files changed, 93 insertions, 0 deletions
diff --git a/meta/recipes-extended/stress/files/texinfo.patch b/meta/recipes-extended/stress/files/texinfo.patch
new file mode 100644
index 0000000000..5ac595192f
--- /dev/null
+++ b/meta/recipes-extended/stress/files/texinfo.patch
@@ -0,0 +1,79 @@
+--- a/doc/stress.texi
++++ b/doc/stress.texi
+@@ -62,47 +62,47 @@
+
+ @table @samp
+ @item -?
+-@itemx --help
++@item --help
+ Show help information.
+
+-@itemx --version
++@item --version
+ Show version information.
+
+ @item -v
+-@itemx --verbose
++@item --verbose
+ Turn up verbosity.
+
+ @item -q
+-@itemx --quiet
++@item --quiet
+ Turn down verbosity.
+
+ @item -n
+-@itemx --dry-run
++@item --dry-run
+ Show what would have been done.
+
+ @item -t @var{secs}
+-@itemx --timeout @var{secs}
++@item --timeout @var{secs}
+ Time out after @var{secs} seconds.
+
+-@itemx --backoff @var{usecs}
++@item --backoff @var{usecs}
+ Wait for factor of @var{usecs} microseconds before starting work.
+
+ @item -c @var{forks}
+-@itemx --cpu @var{forks}
++@item --cpu @var{forks}
+ Spawn @var{forks} processes each spinning on @samp{sqrt()}.
+
+ @item -i @var{forks}
+-@itemx --io @var{forks}
++@item --io @var{forks}
+ Spawn @var{forks} processes each spinning on @samp{sync()}.
+
+ @item -m @var{forks}
+-@itemx --vm @var{forks}
++@item --vm @var{forks}
+ Spawn @var{forks} processes each spinning on @samp{malloc()}.
+
+-@itemx --vm-bytes @var{bytes}
++@item --vm-bytes @var{bytes}
+ Allocate @var{bytes} number of bytes. The default is 1.
+
+-@itemx --vm-hang
++@item --vm-hang
+ Instruct each vm hog process to go to sleep after allocating memory. This
+ contrasts with their normal behavior, which is to free the memory and
+ reallocate @emph{ad infinitum}. This is useful for simulating low memory
+@@ -114,13 +114,13 @@
+ @end example
+
+ @item -d @var{forks}
+-@itemx --hdd @var{forks}
++@item --hdd @var{forks}
+ Spawn @var{forks} processes each spinning on @samp{write()}.
+
+-@itemx --hdd-bytes @var{bytes}
++@item --hdd-bytes @var{bytes}
+ Write @var{bytes} number of bytes. The default is 1GB.
+
+-@itemx --hdd-noclean
++@item --hdd-noclean
+ Do not unlink file(s) to which random ASCII data is written.
+
+ @end table
diff --git a/meta/recipes-extended/stress/stress_1.0.4.bb b/meta/recipes-extended/stress/stress_1.0.4.bb
new file mode 100644
index 0000000000..44f2fc64dd
--- /dev/null
+++ b/meta/recipes-extended/stress/stress_1.0.4.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
+imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
+HOMEPAGE = "http://people.seas.harvard.edu/~apw/stress/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/stress/stress-${PV}.tar.gz/a607afa695a511765b40993a64c6e2f4/stress-${PV}.tar.gz \
+ file://texinfo.patch \
+ "
+
+SRC_URI[md5sum] = "a607afa695a511765b40993a64c6e2f4"
+SRC_URI[sha256sum] = "369c997f65e8426ae8b318d4fdc8e6f07a311cfa77cc4b25dace465c582163c0"
+
+inherit autotools