aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-11-09 01:56:00 -0500
committerChen Qi <Qi.Chen@windriver.com>2014-11-09 15:02:04 +0800
commitcb7ccb68e82c104d668177b180577673c86fc5df (patch)
tree5a61e2ee573a08be3333237912a60d53b8c0cc60
parentd7a277b35bcc67050046c76fb70412101679a545 (diff)
downloadopenembedded-core-contrib-cb7ccb68e82c104d668177b180577673c86fc5df.tar.gz
procps: install symlink under /etc/sysctl.d in case of systemdChenQi/procps-sysctl.d
Install /etc/sysctl.d/99-sysctl.conf symlink in case of systemd so that /etc/sysctl.conf is taken into consideration by systemd-sysctl. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-extended/procps/procps_3.2.8.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.2.8.bb b/meta/recipes-extended/procps/procps_3.2.8.bb
index 6211a7c955..fcfde194f1 100644
--- a/meta/recipes-extended/procps/procps_3.2.8.bb
+++ b/meta/recipes-extended/procps/procps_3.2.8.bb
@@ -28,6 +28,10 @@ EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -I${STAGING_INCDIR}" \
do_install_append () {
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/sysctl.d
+ ln -sf ../sysctl.conf ${D}${sysconfdir}/sysctl.d/99-sysctl.conf
+ fi
}
CONFFILES_${PN} = "${sysconfdir}/sysctl.conf"