aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2014-08-13 00:36:54 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-15 18:19:53 +0100
commit3682d661f3b3a6fa7d9ef37968746cbaf1ede078 (patch)
tree43adfb174fffd0f8533af69b8a258ba69f8c3a29
parente668c79de927eff635f29fb5ff001f6b106ccc81 (diff)
downloadopenembedded-core-contrib-3682d661f3b3a6fa7d9ef37968746cbaf1ede078.tar.gz
curl: let configure find gnutls via pkg-config
Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/curl/curl_7.37.1.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta/recipes-support/curl/curl_7.37.1.bb b/meta/recipes-support/curl/curl_7.37.1.bb
index e51e06d522..4b7f9ec922 100644
--- a/meta/recipes-support/curl/curl_7.37.1.bb
+++ b/meta/recipes-support/curl/curl_7.37.1.bb
@@ -25,7 +25,7 @@ PACKAGECONFIG_class-nativesdk = "ipv6 ssl zlib"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
PACKAGECONFIG[ssl] = "--with-ssl,--without-ssl,openssl"
-PACKAGECONFIG[gnutls] = "--with-gnutls=${STAGING_LIBDIR}/../,--without-gnutls,gnutls"
+PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
EXTRA_OECONF = "--without-libssh2 \
@@ -37,10 +37,6 @@ EXTRA_OECONF = "--without-libssh2 \
--with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
"
-do_configure_prepend() {
- sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac
-}
-
do_install_append() {
oe_multilib_header curl/curlbuild.h
}