aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-05-29 09:50:53 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-30 16:31:22 +0100
commit675fd834b9ed696cd87809830d57d3da083580d3 (patch)
treec917dc3a236d154284a6dc2fc4e6a20df41d2931
parent2a36a02c2444551579b8498468debfaff0faa6d8 (diff)
downloadopenembedded-core-contrib-675fd834b9ed696cd87809830d57d3da083580d3.tar.gz
update-rc.d: fix to handle priority numbers correctly
The update-rc.d treated priority numbers begin with '0' as octal numbers. This led to problems of update-rc.d being unable to handle priorities like '08' or '09' correctly. This patch fixes the above problem. [YOCTO #6376] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/update-rc.d/update-rc.d/fix-to-handle-priority-numbers-correctly.patch28
-rw-r--r--meta/recipes-core/update-rc.d/update-rc.d_0.7.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/update-rc.d/update-rc.d/fix-to-handle-priority-numbers-correctly.patch b/meta/recipes-core/update-rc.d/update-rc.d/fix-to-handle-priority-numbers-correctly.patch
new file mode 100644
index 0000000000..85bc234a27
--- /dev/null
+++ b/meta/recipes-core/update-rc.d/update-rc.d/fix-to-handle-priority-numbers-correctly.patch
@@ -0,0 +1,28 @@
+Upstream-Status: Pending
+
+Fix to handle priority numbers correctly.
+Previously, if the priority number is '08' or '09', for example,
+the script cannot handle them correctly as these numbers are treated
+as octal numbers.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ update-rc.d | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/update-rc.d b/update-rc.d
+index ec50d15..c70b859 100644
+--- a/update-rc.d
++++ b/update-rc.d
+@@ -205,7 +205,7 @@ case $1 in
+ exit 1
+ fi
+ shift
+- NN=`printf %02d $1`
++ NN=`printf %02d $(expr $1 + 0)`
+ shift
+ while [ "x$1" != "x." ]; do
+ if [ $# -eq 0 ]; then
+--
+1.7.9.5
+
diff --git a/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb b/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
index 50dcaa2d3f..c15cb78033 100644
--- a/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
+++ b/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
@@ -13,6 +13,7 @@ SRCREV = "eca680ddf28d024954895f59a241a622dd575c11"
SRC_URI = "git://github.com/philb/update-rc.d.git \
file://add-verbose.patch \
file://check-if-symlinks-are-valid.patch \
+ file://fix-to-handle-priority-numbers-correctly.patch \
"
S = "${WORKDIR}/git"