summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-11-25 18:22:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-27 13:23:27 +0000
commit04f7e28963b413b88724c80f67787b440793570e (patch)
tree3eeedf94f1c4235715bebe610aefeafff99fdabc
parent8c164bb34b777db2cc3ed723d8397ce6fa040aac (diff)
downloadopenembedded-core-contrib-04f7e28963b413b88724c80f67787b440793570e.tar.gz
python-native: don't cause a full regeneration of the built sources
When cross-compiling Python 2 you need a native pgen binary, but the cross recipe can't do this on it's own so we build it in python-native and install it. The rule to build pgen was also causing a complete rebuild of all of the generated sources, which meant that building Python 2 needs a *host* Python 2. This can be fixed by simply building pgen, as this is all we need to install. [ YOCTO #13645 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.17.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.17.bb b/meta/recipes-devtools/python/python-native_2.7.17.bb
index 936810d980..98805d998d 100644
--- a/meta/recipes-devtools/python/python-native_2.7.17.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.17.bb
@@ -35,10 +35,9 @@ do_configure_append() {
autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
}
-# Regenerate all of the generated files
-# This ensures that pgen and friends get created during the compile phase
-do_compile_prepend() {
- oe_runmake regen-all
+# Cross-compiling Python needs a native pgen, build it here for use later.
+do_compile_append() {
+ oe_runmake Parser/pgen
}
do_install() {