summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-11-25 18:22:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-27 13:23:27 +0000
commit8c164bb34b777db2cc3ed723d8397ce6fa040aac (patch)
tree9a139408cf8261dfbdee2d7c6f5cbad72f11906b
parent5a0df07de5f18e701bdcb6004c9883838cb0d5c9 (diff)
downloadopenembedded-core-contrib-8c164bb34b777db2cc3ed723d8397ce6fa040aac.tar.gz
u-boot: update to 2020.01-rc3 pre-release and drop py2 dependencies
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-common.inc5
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb (renamed from meta/recipes-bsp/u-boot/u-boot-fw-utils_2019.10.bb)0
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb (renamed from meta/recipes-bsp/u-boot/u-boot-tools_2019.10.bb)0
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc6
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2020.01.bb (renamed from meta/recipes-bsp/u-boot/u-boot_2019.10.bb)0
5 files changed, 7 insertions, 4 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-common.inc b/meta/recipes-bsp/u-boot/u-boot-common.inc
index c3e458e925..a0f9c41469 100644
--- a/meta/recipes-bsp/u-boot/u-boot-common.inc
+++ b/meta/recipes-bsp/u-boot/u-boot-common.inc
@@ -10,9 +10,12 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
PE = "1"
+# Drop this line when updating to 2020.01 final
+PV = "2020.01~rc3"
+
# We use the revision in order to avoid having to fetch it from the
# repo during parse
-SRCREV = "61ba1244b548463dbfb3c5285b6b22e7c772c5bd"
+SRCREV = "d4a31e8ee5592072d8d5208b3e950cba2d89b6bd"
SRC_URI = "git://git.denx.de/u-boot.git \
"
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2019.10.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb
index 04321b7b66..04321b7b66 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2019.10.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2020.01.bb
diff --git a/meta/recipes-bsp/u-boot/u-boot-tools_2019.10.bb b/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
index bede984ef7..bede984ef7 100644
--- a/meta/recipes-bsp/u-boot/u-boot-tools_2019.10.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 9a754fd09b..55d8b47870 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -7,13 +7,13 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
DEPENDS += "kern-tools-native"
-inherit uboot-config uboot-extlinux-config uboot-sign deploy cml1
+inherit uboot-config uboot-extlinux-config uboot-sign deploy cml1 python3native
-DEPENDS += "swig-native python-native"
+DEPENDS += "swig-native"
EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
-EXTRA_OEMAKE += 'PYTHON2=nativepython STAGING_INCDIR=${STAGING_INCDIR_NATIVE} STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE}'
+EXTRA_OEMAKE += 'STAGING_INCDIR=${STAGING_INCDIR_NATIVE} STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE}'
PACKAGECONFIG ??= "openssl"
# u-boot will compile its own tools during the build, with specific
diff --git a/meta/recipes-bsp/u-boot/u-boot_2019.10.bb b/meta/recipes-bsp/u-boot/u-boot_2020.01.bb
index 02d67c0db2..02d67c0db2 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2019.10.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2020.01.bb