summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Rapeli <mikko.rapeli@bmw.de>2019-11-07 15:39:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-10 14:04:55 +0000
commiteb661eaa2067e91b533fb077479be5432b6e586b (patch)
tree78b29ceff3159f818ff6ffc9a38660256182cd8d
parente462f47489f35902b6972f9837d9adfa542fc796 (diff)
downloadopenembedded-core-contrib-eb661eaa2067e91b533fb077479be5432b6e586b.tar.gz
harfbuzz: split libharfbuzz-subset.so to its own binary package
harfbuzz binary package size increased from 624608 bytes in yocto 2.5 to 1365431 bytes in yocto 3.0. Most of the size increase is in the new libharfbuzz-subset.so* library https://harfbuzz.github.io/utilities.html#utilities-command-line-hbsubset Split it to its own binary package which will be installed if anyone needs it. Effect to harfbuzz binary package size is: -PKGSIZE = 1476271 +PKGSIZE = 1007424 Signed-off-by: Mikko Rapeli <mikko.rapeli@bmw.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
index 99cd4cd708..80ab545e08 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
@@ -21,7 +21,7 @@ PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
-PACKAGES =+ "${PN}-icu ${PN}-icu-dev"
+PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
LEAD_SONAME = "libharfbuzz.so"
@@ -36,5 +36,6 @@ FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
${libdir}/libharfbuzz-icu.so \
${libdir}/pkgconfig/harfbuzz-icu.pc \
"
+FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
BBCLASSEXTEND = "native nativesdk"