summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-12-07 11:52:07 -0500
committerAnuj Mittal <anuj.mittal@intel.com>2021-12-10 11:29:49 +0800
commit31125411003d5790398ad776885bf87df6def3ee (patch)
tree613ac5d819c941c085e9fe4de51f054d3223429b
parent43478c509c5c58c09cb67989a3d22bce9761f6ba (diff)
downloadopenembedded-core-contrib-31125411003d5790398ad776885bf87df6def3ee.tar.gz
linux-yocto-rt/5.10: update to -rt56
Integrating the following commit(s) to linux-yocto-rt/5.10: 23f3ad608bc7 rcutorture: fixup merge from standard/base -stable 8612be3f3e2b Revert "rcutorture: Avoid problematic critical section nesting on RT" 9a6fb5667ac8 Linux 5.10.78-rt56 78c80dca8b1f irq_work: Also rcuwait for !IRQ_WORK_HARD_IRQ on PREEMPT_RT e91d3b98e3b3 irq_work: Handle some irq_work in a per-CPU thread on PREEMPT_RT bded6a156d4e irq_work: Allow irq_work_sync() to sleep if irq_work() no IRQ support. 747c881d3348 drm/i915/gt: Queue and wait for the irq_work item. fa4ef0011e58 locking: Drop might_resched() from might_sleep_no_state_check() f44d86bc5923 fscache: Use only one fscache_object_cong_wait. 2da5bc42a911 fscache: Use only one fscache_object_cong_wait. 53ecacfc9c68 mm: Disable NUMA_BALANCING_DEFAULT_ENABLED and TRANSPARENT_HUGEPAGE on PREEMPT_RT 03bdef3c5563 preempt: Move preempt_enable_no_resched() to the RT block 0def39751031 sched: Switch wait_task_inactive to HRTIMER_MODE_REL_HARD 60df07c6bd86 sched: Fix get_push_task() vs migrate_disable() 27f8594efeac mm, zsmalloc: Convert zsmalloc_handle.lock to spinlock_t 3fcbcd86a8eb Linux 5.10.78-rt55 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 29f8c47f1d61eb702bd9af72e81708ca66ca9c09) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.10.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
index 977856376c..47f8ff27ee 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "d007a2fd6964323f58564a7362cb0293bc69c5bf"
-SRCREV_meta ?= "e2f792a996eb4ace257b7dd12d3890ce504741c3"
+SRCREV_machine ?= "23f3ad608bc75fc89f49a533ac4e5ed8deaa33b0"
+SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
index d1309861d9..d9bec45691 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine:qemuarm ?= "01f85f09232df2aa45edd757150cb03e35f41f3b"
SRCREV_machine ?= "f0a0ddc2f355d02a706454137d3dab7889fcf4d1"
-SRCREV_meta ?= "e2f792a996eb4ace257b7dd12d3890ce504741c3"
+SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.10.bb b/meta/recipes-kernel/linux/linux-yocto_5.10.bb
index c007768dc0..63d7670f80 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.10.bb
@@ -23,7 +23,7 @@ SRCREV_machine:qemux86 ?= "1bb9d730ac6630d3f41c2ef529fab09f12bcf07d"
SRCREV_machine:qemux86-64 ?= "1bb9d730ac6630d3f41c2ef529fab09f12bcf07d"
SRCREV_machine:qemumips64 ?= "690b09d3a24bafeff32bb06a72643be0c8fae9a7"
SRCREV_machine ?= "1bb9d730ac6630d3f41c2ef529fab09f12bcf07d"
-SRCREV_meta ?= "e2f792a996eb4ace257b7dd12d3890ce504741c3"
+SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
# remap qemuarm to qemuarma15 for the 5.8 kernel
# KMACHINE:qemuarm ?= "qemuarma15"