aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-10-11 16:11:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-18 15:47:11 +0100
commite0b56f7ed84da4f71f448548e15d5a75e8eada6e (patch)
tree0de9f4d382c69df0906cb6218d71912bb2da8b5a
parent13c9bc143f6861517970dafdc7e7a45740d0933d (diff)
downloadopenembedded-core-contrib-e0b56f7ed84da4f71f448548e15d5a75e8eada6e.tar.gz
perf: flag __SANE_USERSPACE_TYPES__ to include int-ll64.h for powerpc64
PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h prevents 64-bit userland from seeing this definition, instead defaulting to u64 == long in userspace. Perf want LL64, flag __SANE_USERSPACE_TYPES__ to get int-ll64.h. Fix the below issue: | tests/attr.c:71:4: error: format '%llu' expects argument of type 'long long unsigned int', but argument 6 has type '__u64' [-Werror=format=] | tests/attr.c:80:7: error: format '%llu' expects argument of type 'long long unsigned int', but argument 4 has type '__u64' [-Werror=format=] | attr->type, attr->config, fd) < 0) { | ^ Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-kernel/perf/perf.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 269069f3af..d27e535605 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -89,6 +89,12 @@ EXTRA_OEMAKE += "\
'infodir=${@oe.path.relative(prefix, infodir)}' \
"
+# PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h
+# prevents 64-bit userland from seeing this definition, instead defaulting
+# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
+# int-ll64.h included.
+EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
+
PARALLEL_MAKE = ""
do_compile() {