aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-02 21:00:49 -0800
committerDan McGregor <dan.mcgregor@usask.ca>2015-02-06 11:21:29 -0600
commit518a8a8bfdf07b1508401e60f2dfcf6ce6bdc123 (patch)
tree400ae1e7851a18fe0e190283a89e94440c9b4fa1
parent0fa37628e7af9077fa115cdf589aeabf1cf9d626 (diff)
downloadopenembedded-core-contrib-518a8a8bfdf07b1508401e60f2dfcf6ce6bdc123.tar.gz
glibc: Disable -mfpmath=sse during build for x86_64
Fixes errors like > /data/poky-master/tmp/work/corei7-64-poky-linux/glibc/2.21-r0/build-x86_64-poky-linux/elf/dl-open.os > | dl-caller.c:1:0: error: SSE instruction set disabled, using 387 > arithmetics [-Werror] > | /* Check whether caller comes from the right place. > | ^ > | dl-open.c:1:0: error: SSE instruction set disabled, using 387 > arithmetics > [-Werror] Change-Id: Ib4e745828ce9fb4eef94363bc55556448ebd943c Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index ce4fc015d2..c76b0a2667 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -105,6 +105,7 @@ do_patch_append() {
TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
+TUNE_CCARGS_x86-64 := "${@oe_filter_out('-mfpmath=sse', '${TUNE_CCARGS}', d)}"
do_fix_readlib_c () {
sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c