summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-04-04 11:19:13 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-05 10:48:34 +0100
commitfda812765b9e88d5bdf0fa5684ff968f413ef35c (patch)
tree3190cd728c45a76b4c2b3d3ae4e68ca348396095
parentdb6a636319ffd2b12c54b6ec1b3fdd670f9b6704 (diff)
downloadopenembedded-core-contrib-fda812765b9e88d5bdf0fa5684ff968f413ef35c.tar.gz
linux-yocto/5.15: aufs: fixes and optimization
Integrating the following commit(s) to linux-yocto/5.15: b98d189df02c aufs: bugfix, umount passes NULL to ->parse_monolithic() 13b883cbbbd9 aufs standalone: cosmetic, missing copyright sentence 21f8b0d81898 aufs: 5.15.5-20220117 ---> 5.15.5-20220221 6199fd896645 aufs: tiny, headers after fs_context 8ddb40e31c29 aufs: fs_context 7/7, finally remount 69035f71c6fd aufs: fs_context 6/7, now mount bc841b970697 aufs: fs_context 5/7, parse all other mount options 435188053da2 aufs: fs_context 4/7, parse xino options 9af1f1825cbd aufs: fs_context 3/7, parse the branch-management options 1c05eb767f8c aufs: fs_context 2/7, parse "br" mount option a8488f603134 aufs: fs_context 1/7, skelton of the new shceme 8e32e0015564 aufs: pre fs_context, convert a static flag to a macro f90cb4144aec aufs: pre fs_context, support the incomplete sb and sbinfo case 948762ef859c aufs: pre fs_context, convert the type of alloc_sbinfo() 77151a08776b aufs: 5.15.5-20211129 ---> 5.15.5-20220117 2539adbbbe1e aufs: 5.14-20211018 ---> 5.15.5-20211129 7d32b25193c4 aufs: for v5.15-rc1, sync_inode() is gone 66ec0c509225 aufs: for v5.15-rc1, new param 'rcu' for ->get_acl() 69709dc518cd aufs: for v5.15-rc1, no mand-lock anymore ada8fe9543e5 aufs: 5.14-20210906 ---> 5.14-20211018 b77f7f3f394a Revert "aufs: adjust to v5.15 fs changes" Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.15.bb20
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
index d28bfaa62e..4efe51ec6b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.15.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "3b3fed8f3b6d6d691ed4ebc270ed13fc4f24a0b7"
+SRCREV_machine ?= "2982a893fea6919a3ffd1fb6d600fb8cfe8c58b4"
SRCREV_meta ?= "7dd85143b4ed77bdcb6628ac8ea69917e1cd29e5"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
index 7b42986357..d5b301b4d5 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
@@ -15,8 +15,8 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine:qemuarm ?= "6a4187344f4b0c1a0e372124a55d164c4db1c1fc"
-SRCREV_machine ?= "38eee29b552caba70723f16b5b7e6c47237baea7"
+SRCREV_machine:qemuarm ?= "cc9e92e826af229b841fcaf8c645e638a86eba43"
+SRCREV_machine ?= "c3d54a67cbf3fb8e6df2d88c80e9d2c74f69aba4"
SRCREV_meta ?= "7dd85143b4ed77bdcb6628ac8ea69917e1cd29e5"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.15.bb b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
index 29448ec237..b936257aa7 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
@@ -13,16 +13,16 @@ KBRANCH:qemux86 ?= "v5.15/standard/base"
KBRANCH:qemux86-64 ?= "v5.15/standard/base"
KBRANCH:qemumips64 ?= "v5.15/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "f6561f66ec8485b0f55fa5c09e3614d85e65da77"
-SRCREV_machine:qemuarm64 ?= "182d2a0dfea7f5a869b8938b5c50fd46153047ff"
-SRCREV_machine:qemumips ?= "5954e50bf90b3e22361b335b3fab47fcbd14a88e"
-SRCREV_machine:qemuppc ?= "114761d623636cafa01bb60b3e0e9262f21d2d56"
-SRCREV_machine:qemuriscv64 ?= "ee43e792dbdecc18d6d72c360712659fc78b997f"
-SRCREV_machine:qemuriscv32 ?= "ee43e792dbdecc18d6d72c360712659fc78b997f"
-SRCREV_machine:qemux86 ?= "ee43e792dbdecc18d6d72c360712659fc78b997f"
-SRCREV_machine:qemux86-64 ?= "ee43e792dbdecc18d6d72c360712659fc78b997f"
-SRCREV_machine:qemumips64 ?= "f57326efb3ee9cba3f867b65b7535d3819da7933"
-SRCREV_machine ?= "ee43e792dbdecc18d6d72c360712659fc78b997f"
+SRCREV_machine:qemuarm ?= "b6fd1a7dd80a336567fa30c1d674f0d5df9af836"
+SRCREV_machine:qemuarm64 ?= "387a676543764b59e38cf6b13d6474846fb07d78"
+SRCREV_machine:qemumips ?= "7c084cf3a700f7a2c68c8909501f4d35b3215e40"
+SRCREV_machine:qemuppc ?= "239f7c8f37bf9ade16325101df3c06a485ccc74e"
+SRCREV_machine:qemuriscv64 ?= "c9f3902d8069e32a8928153a38d8f6115194d128"
+SRCREV_machine:qemuriscv32 ?= "c9f3902d8069e32a8928153a38d8f6115194d128"
+SRCREV_machine:qemux86 ?= "c9f3902d8069e32a8928153a38d8f6115194d128"
+SRCREV_machine:qemux86-64 ?= "c9f3902d8069e32a8928153a38d8f6115194d128"
+SRCREV_machine:qemumips64 ?= "a4805fe749c9c56d18a60b5378674760ef0e85ed"
+SRCREV_machine ?= "c9f3902d8069e32a8928153a38d8f6115194d128"
SRCREV_meta ?= "7dd85143b4ed77bdcb6628ac8ea69917e1cd29e5"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll