summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Weiss <simone.weiss@elektrobit.com>2022-04-01 16:46:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-03 10:40:27 +0100
commitffae118e7b1bdf704d9af0ad47809c3791b672b4 (patch)
tree6028cc66ca50881bb0f418f0a13c502571574714
parent261778c1e3665b34c0d4e49bda63b520d5335587 (diff)
downloadopenembedded-core-contrib-ffae118e7b1bdf704d9af0ad47809c3791b672b4.tar.gz
popt: add ptest
Add a ptest for popt to core-image-ptest-all. Provide a patch to popt to adopt the test format to "simple test" and a script for running the test. All tests passed on a trial run. Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com> Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/distro/include/ptest-packagelists.inc1
-rw-r--r--meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch68
-rw-r--r--meta/recipes-support/popt/popt/run-ptest3
-rw-r--r--meta/recipes-support/popt/popt_1.18.bb21
4 files changed, 91 insertions, 2 deletions
diff --git a/meta/conf/distro/include/ptest-packagelists.inc b/meta/conf/distro/include/ptest-packagelists.inc
index ac3295d1aa..b51cce4d9e 100644
--- a/meta/conf/distro/include/ptest-packagelists.inc
+++ b/meta/conf/distro/include/ptest-packagelists.inc
@@ -48,6 +48,7 @@ PTESTS_FAST = "\
opkg-ptest \
pango-ptest \
parted-ptest \
+ popt-ptest \
python3-atomicwrites-ptest \
python3-bcrypt-ptest \
python3-hypothesis-ptest \
diff --git a/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
new file mode 100644
index 0000000000..020949cc34
--- /dev/null
+++ b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
@@ -0,0 +1,68 @@
+From 330b77081c3a4c7ae76cb08602db385b40fa7ff7 Mon Sep 17 00:00:00 2001
+From: Simone Weiss <simone.weiss@elektrobit.com>
+Date: Mon, 13 Dec 2021 09:29:53 +0000
+Subject: [PATCH] popt test output format for ptest
+
+patch test output format to match simple-test as it is used in ptests.
+
+Upstream-Status: Pending
+
+Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
+Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
+---
+ tests/testit.sh | 20 ++++++++------------
+ 1 file changed, 8 insertions(+), 12 deletions(-)
+
+diff --git a/tests/testit.sh b/tests/testit.sh
+index 2a7b4aa..50b42e2 100755
+--- a/tests/testit.sh
++++ b/tests/testit.sh
+@@ -5,12 +5,11 @@ run() {
+ name=$1; shift
+ answer=$1; shift
+
+- echo Running test $name.
+-
+ result=`HOME=$builddir $builddir/$prog $*`
+ if [ "$answer" != "$result" ]; then
+- echo "Test \"$prog $*\" failed with: \"$result\" != \"$answer\" "
+- exit 2
++ echo "FAIL: $name"
++ else
++ echo "PASS: $name"
+ fi
+ }
+
+@@ -23,17 +22,17 @@ run_diff() {
+ out=$builddir/tmp.out
+ diff_file=$builddir/tmp.diff
+
+- echo Running test $name.
+-
+ $builddir/$prog $in_file > $out
+ ret=$?
+ diff $out $answer_file > $diff_file
+ diff_ret=$?
+
+ if [ "$diff_ret" != "0" ]; then
+- echo "Test \"$name\" failed output is in $out, diff is:"
+- cat $diff_file
+- exit 2
++ echo "FAIL: $name"
++ echo "diff is:"
++ cat $diff_file
++ else
++ echo "PASS: $name"
+ fi
+ rm $out $diff_file
+ }
+@@ -174,6 +173,3 @@ Help options:
+ #run_diff test3 "test3 - 51" test3-data/01.input test3-data/01.answer
+ #run_diff test3 "test3 - 52" test3-data/02.input test3-data/02.answer
+ #run_diff test3 "test3 - 53" test3-data/03.input test3-data/03.answer
+-
+-echo ""
+-echo "Passed."
+--
+2.17.1
+
diff --git a/meta/recipes-support/popt/popt/run-ptest b/meta/recipes-support/popt/popt/run-ptest
new file mode 100644
index 0000000000..85754035d0
--- /dev/null
+++ b/meta/recipes-support/popt/popt/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+./testit.sh
diff --git a/meta/recipes-support/popt/popt_1.18.bb b/meta/recipes-support/popt/popt_1.18.bb
index 057c44f223..af8add4ad6 100644
--- a/meta/recipes-support/popt/popt_1.18.bb
+++ b/meta/recipes-support/popt/popt_1.18.bb
@@ -8,9 +8,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d"
DEPENDS = "virtual/libiconv"
-SRC_URI = "http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz"
+SRC_URI = "\
+ http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \
+ file://0001-popt-test-output-format-for-ptest.patch \
+ file://run-ptest \
+"
SRC_URI[sha256sum] = "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1"
-inherit autotools gettext
+inherit autotools gettext ptest
+
+RDEPENDS_${PN}-ptest += "bash"
+
+do_compile_ptest() {
+ sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh
+}
+
+do_install_ptest() {
+ install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
+ install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
+ install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
+ install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
+}
BBCLASSEXTEND = "native nativesdk"