aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-08 11:37:23 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 21:26:39 +0000
commitcec0102647e3f2c93de5125c1de2436b4b787bdd (patch)
treee1ed8846c5167486e1377abeb166cc56a3bc5bfa
parenta3409b909d20bd91a4e44d9c09dab2471ce4dac5 (diff)
downloadopenembedded-core-contrib-cec0102647e3f2c93de5125c1de2436b4b787bdd.tar.gz
tcltk: Fix for ${B} != ${S}
This change allows ${B} != ${S} builds to work since otherwise gnu-configise is executed in the wrong places and various source paths aren't correct. (From OE-Core rev: e0705e4801a9855a4289d18e653c35190021206e) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.5.13.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.5.13.bb b/meta/recipes-devtools/tcltk/tcl_8.5.13.bb
index 27a9ef66c1..01fe36dc97 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.5.13.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.5.13.bb
@@ -34,12 +34,12 @@ DEPENDS_class-native = ""
EXTRA_OECONF = "--enable-threads --disable-rpath"
do_configure() {
- gnu-configize
+ ( cd ${S}; gnu-configize )
oe_runconf
}
do_compile_prepend() {
- echo > ../compat/fixstrtod.c
+ echo > ${S}/../compat/fixstrtod.c
}
do_install() {
@@ -52,7 +52,7 @@ do_install() {
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
cd ..
- for dir in compat generic unix
+ for dir in ${S}/../compat ${S}/../generic ${S}/../unix
do
install -d ${D}${includedir}/tcl${PV}/$dir
install -m 0644 $dir/*.h ${D}${includedir}/tcl${PV}/$dir/