aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 01:13:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:18:23 +0000
commitde258a9e90d2cc043c3cddc62dccdc1bff8c86ee (patch)
tree99e36434f2ab31aeab06cc24ff410efe4df4a7de
parent05239ff8ef0a95aa6dc960e443f0a3af0a5ce997 (diff)
downloadopenembedded-core-contrib-de258a9e90d2cc043c3cddc62dccdc1bff8c86ee.tar.gz
cross-localedef-native: Fix case where ${B} != ${S}
This change allows ${B} != ${S} builds to work since otherwise configure isn't found. (From OE-Core rev: 68f447c46596387f95072743926298fc64cdd3b9) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.17.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb
index 0fedfad641..1d3c22bf57 100644
--- a/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.17.bb
@@ -39,11 +39,11 @@ EXTRA_OECONF = "--with-glibc=${WORKDIR}/eglibc-${PV}/libc"
CFLAGS += "-DNOT_IN_libc=1"
do_configure () {
- ./configure ${EXTRA_OECONF}
+ ${S}/configure ${EXTRA_OECONF}
}
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
+ install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
}