aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-01-16 13:42:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:47:21 +0000
commitbc14d82c0e5fb20b4967023152a9af1683fb2f2e (patch)
tree75b9bac2144bf15c5aacb64c83857abaa7e8c6ba
parent73adcf1b668f990624411060da253d84f53eb1ee (diff)
downloadopenembedded-core-contrib-bc14d82c0e5fb20b4967023152a9af1683fb2f2e.tar.gz
perf: add PACKAGECONFIG for systemtap
Otherwise it's possible to race with systemtap headers being present during the autodetection and disappearing during the build: tests/sdt.c:14:21: fatal error: sys/sdt.h: No such file or directory #include <sys/sdt.h> ^ (From OE-Core rev: 8aafed5f4757550f2ff688e1b8981e5e8e6e3428) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 8b5028ea4c..acbb1d9038 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -20,6 +20,7 @@ PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python"
PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
+PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
DEPENDS = " \
virtual/${MLPREFIX}libc \