aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-03-19 15:55:13 +0100
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-05-09 18:17:12 +0200
commit946c8d29f63e848e26761fce791f0d5c9c221f11 (patch)
tree714e66458352329ffaa5063ae7c6e370f38fbc24
parentadf1b37433cf37cfab64e0a1945e95d691c88f21 (diff)
downloadopenembedded-core-contrib-946c8d29f63e848e26761fce791f0d5c9c221f11.tar.gz
rpcbind: disable yellow pages support
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind/rpcbind-01-no-yp-support.patch49
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind_0.2.0.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-extended/rpcbind/rpcbind/rpcbind-01-no-yp-support.patch b/meta/recipes-extended/rpcbind/rpcbind/rpcbind-01-no-yp-support.patch
new file mode 100644
index 0000000000..db26214328
--- /dev/null
+++ b/meta/recipes-extended/rpcbind/rpcbind/rpcbind-01-no-yp-support.patch
@@ -0,0 +1,49 @@
+Remove yellow pages support
+
+This support requires yellow pages support in libtirpc, which isn't
+available. As most Buildroot users are most likely never going to need
+such feature, get rid of it.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Upstream-Status: inappropriate [embedded specific]
+
+Index: b/src/security.c
+===================================================================
+--- a/src/security.c
++++ b/src/security.c
+@@ -23,9 +23,6 @@
+ #include <rpcsvc/mount.h>
+ #include <rpcsvc/rquota.h>
+ #include <rpcsvc/nfs_prot.h>
+-#include <rpcsvc/yp.h>
+-#include <rpcsvc/ypclnt.h>
+-#include <rpcsvc/yppasswd.h>
+
+ #include "rpcbind.h"
+
+@@ -322,24 +319,9 @@
+ args->rmt_proc != MOUNTPROC_UMNT)
+ break;
+ goto deny;
+- case YPBINDPROG:
+- if (args->rmt_proc != YPBINDPROC_SETDOM)
+- break;
+- /* FALLTHROUGH */
+- case YPPASSWDPROG:
+ case NFS_PROGRAM:
+ case RQUOTAPROG:
+ goto deny;
+- case YPPROG:
+- switch (args->rmt_proc) {
+- case YPPROC_ALL:
+- case YPPROC_MATCH:
+- case YPPROC_FIRST:
+- case YPPROC_NEXT:
+- goto deny;
+- default:
+- break;
+- }
+ default:
+ break;
+ }
diff --git a/meta/recipes-extended/rpcbind/rpcbind_0.2.0.bb b/meta/recipes-extended/rpcbind/rpcbind_0.2.0.bb
index 10076138bf..0a1b2d9f7d 100644
--- a/meta/recipes-extended/rpcbind/rpcbind_0.2.0.bb
+++ b/meta/recipes-extended/rpcbind/rpcbind_0.2.0.bb
@@ -14,6 +14,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
file://init.d \
file://fix_host_path.patch \
file://obsolete_automake_macros.patch \
+ file://rpcbind-01-no-yp-support.patch \
${UCLIBCPATCHES} \
"