summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-05-20 14:36:09 +0200
committerMartin Jansa <martin.jansa@gmail.com>2024-05-20 16:09:13 +0200
commitb147c21ebe1b238328cf12208e3b50bb9e2d8bb3 (patch)
treec263719daed221acdcc6fe997d555df6de09c60b
parent46318ac56eb3513be0ee930db67d8260b24d31fa (diff)
downloadopenembedded-core-contrib-jansa/master-gcc14.tar.gz
cdrtools-native: fix build with gcc-14jansa/master-gcc14
Fixes: http://errors.yoctoproject.org/Errors/Details/770525/ | checking whether the C compiler (gcc -isystem/OE/build/oe-core/tmp-glibc/work/x86_64-linux/cdrtools-native/3.01/recipe-sysroot-native/usr/include -O2 -pipe ) works... no | configure: error: installation or configuration problem: C compiler cannot create executables. | RULES/rules.cnf:70: incs/amd-ryzen-threadripper-3970x-32-core-processor-linux-cc/rules.cnf: No such file or directory | make: *** [RULES/rules.cnf:59: incs/amd-ryzen-threadripper-3970x-32-core-processor-linux-cc/rules.cnf] Error 1 | make: *** Waiting for unfinished jobs.... where config.log show it's caused by gcc-14: configure:1189: checking whether the C compiler (gcc -isystem/OE/build/oe-core/tmp-glibc/work/x86_64-linux/cdrtools-native/3.01/recipe-sysroot-native/usr/include -O2 -pipe ) works configure:1211: gcc -o conftest -isystem/OE/build/oe-core/tmp-glibc/work/x86_64-linux/cdrtools-native/3.01/recipe-sysroot-native/usr/include -O2 -pipe -D_GNU_SOURCE conftest.c 1>&5 configure:1208:1: error: return type defaults to 'int' [-Wimplicit-int] configure: failed program was: main(){return(0);} Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb b/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
index bf8be1ad0c..239b351933 100644
--- a/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
+++ b/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
@@ -19,13 +19,17 @@ SRC_URI = " \
SRC_URI[md5sum] = "7d45c5b7e1f78d85d1583b361aee6e8b"
SRC_URI[sha256sum] = "ed282eb6276c4154ce6a0b5dee0bdb81940d0cbbfc7d03f769c4735ef5f5860f"
-EXTRA_OEMAKE = "-e MAKEFLAGS="
+EXTRA_OEMAKE = "-e MAKEFLAGS= CPPOPTX='${CPPFLAGS}' COPTX='${CFLAGS}' C++OPTX='${CXXFLAGS}' LDOPTX='${LDFLAGS}' GMAKE_NOWARN='true'"
# Stop failures when 'cc' can't be found
export ac_cv_prog_CC = "${CC}"
inherit native
+# Use -std=gnu89 to build with gcc-14 (https://bugs.gentoo.org/903876)
+# this needs to be after native inherit (which sets CFLAGS to BUILD_CFLAGS)
+CFLAGS += "-std=gnu89"
+
do_configure() {
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/autoconf
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/autoconf
@@ -33,5 +37,5 @@ do_configure() {
}
do_install() {
- make install GMAKE_NOWARN=true INS_BASE=${prefix} DESTDIR=${D}
+ oe_runmake install INS_BASE=${prefix} DESTDIR=${D}
}