summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex@linutronix.de>2021-08-24 09:52:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-24 09:37:17 +0100
commit91bb0c4180b0e788b4483f836478b7de948029a0 (patch)
treec85562e9e4d1edde6150c9a474cc521b8f740748
parent9ee65c2b980e4081264f4acaddcae8adb7358668 (diff)
downloadopenembedded-core-contrib-91bb0c4180b0e788b4483f836478b7de948029a0.tar.gz
mc: fix reproducibility
It is probing into what options the /usr/bin/file executable does and does not support and bakes that into target binaries, so we need to use a deterministic one we build ourselves. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/mc/mc_4.8.27.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.27.bb b/meta/recipes-extended/mc/mc_4.8.27.bb
index bc2348432b..546e615d1d 100644
--- a/meta/recipes-extended/mc/mc_4.8.27.bb
+++ b/meta/recipes-extended/mc/mc_4.8.27.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "GNU Midnight Commander is a visual file manager, licensed under G
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
SECTION = "console/utils"
-DEPENDS = "ncurses glib-2.0 util-linux"
+DEPENDS = "ncurses glib-2.0 util-linux file-replacement-native"
RDEPENDS:${PN} = "ncurses-terminfo-base"
RRECOMMENDS:${PN} = "ncurses-terminfo"
@@ -14,6 +14,10 @@ SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
"
SRC_URI[sha256sum] = "2f52dd9c75c20d8eac7701bd3a8c6c125aaf8cdd9cf12b78ca50a0102b543407"
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".2"
+
inherit autotools gettext pkgconfig
#
@@ -25,6 +29,7 @@ PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
CFLAGS:append:libc-musl = ' -DNCURSES_WIDECHAR=1 '
EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
+EXTRANATIVEPATH += "file-native"
CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"