summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-05-03 18:10:40 +0100
committerSteve Sakoman <steve@sakoman.com>2021-05-07 05:21:22 -1000
commitb7435fae07c7f6859e951d4796486b4cc65d44bc (patch)
treef351339bb9c9836869e13ca0b68f00dcdcc3adea
parent8dd9cfc0f95366b1ca7fca981d4ae238b6dcb92c (diff)
downloadopenembedded-core-contrib-b7435fae07c7f6859e951d4796486b4cc65d44bc.tar.gz
ptest-runner: libgcc must be installed for pthread_cancel to work
This only affects glibc systems and have been found on runqemu core-image-minimal with gstreamer ptest-runner STOP: ptest-runner libgcc_s.so.1 must be installed for pthread_cancel to work Aborted Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1cb679e6a4528a2cef16f65342d5e65adb14cb16) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
index 8b9938f572..7290dc90e5 100644
--- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
@@ -27,3 +27,5 @@ do_compile () {
do_install () {
install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
}
+
+RDEPENDS_${PN}_append_libc-glibc = " libgcc"