summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-10-08 14:43:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-09 17:21:44 +0100
commit4e6be3fb521b23cfc175d0c09725bcc3ebbc73b2 (patch)
tree173814b6738a6ad4dfc635955a252519e3e36c14
parentcf83790728ad569af01300f793754c0108c78b4e (diff)
downloadopenembedded-core-contrib-4e6be3fb521b23cfc175d0c09725bcc3ebbc73b2.tar.gz
ptest-runner: install -collect-system-data script
When ptest-runner times out or otherwise fails, it tries to call ptest-runner-collect-system-data, so install the script. The script currently calls dmesg, df, free (which are provided by busybox, etc.) and pstree (which is a sub-package of psmisc). Add pstree as an RDEPENDS. Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
index 1d3c24a177..23ab48ba2b 100644
--- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
@@ -15,7 +15,7 @@ SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
S = "${WORKDIR}/git"
-FILES:${PN} = "${bindir}/ptest-runner"
+FILES:${PN} = "${bindir}/ptest-runner ${bindir}/ptest-runner-collect-system-data"
EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
@@ -25,6 +25,10 @@ do_compile () {
do_install () {
install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
+ install -D -m 0755 ${S}/ptest-runner-collect-system-data ${D}${bindir}/ptest-runner-collect-system-data
}
RDEPENDS:${PN}:append:libc-glibc = " libgcc"
+
+# pstree is called by ptest-runner-collect-system-data
+RDEPENDS:${PN}:append = " pstree"