summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérémy Rosen <jeremy.rosen@smile.fr>2023-10-10 15:49:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-10-15 09:11:40 +0100
commit0c91ad29f7ea313bc25481be9d40f216c0770b98 (patch)
tree6f9fe6ea24dac0748540f809d81fe650d904f532
parentbc9013295256443e877f29b7e00605ffa5177efa (diff)
downloadopenembedded-core-contrib-0c91ad29f7ea313bc25481be9d40f216c0770b98.tar.gz
insane: Add a naive heuristic to detect test subdirectories
if there is a "test" or "tests" subdirectory at toplevel, this usually means we have some unit tests available. This test is very good at detecting handcrafted tests and I was not able to find any false positive. False positive can be dealt with the usual INSANE_SKIP mechanism Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr> Reviewed-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
-rw-r--r--meta/classes-global/insane.bbclass4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/classes-global/insane.bbclass b/meta/classes-global/insane.bbclass
index 3fa9da8aff..07de974a54 100644
--- a/meta/classes-global/insane.bbclass
+++ b/meta/classes-global/insane.bbclass
@@ -1391,6 +1391,10 @@ python do_qa_patch() {
elif os.path.exists(os.path.join(srcdir, "Makefile.in")) and (match_line_in_files(srcdir, "**/Makefile.in", r'\s*TESTS\s*\+?=') or match_line_in_files(srcdir,"**/*.at",r'.*AT_INIT')):
oe.qa.handle_error("unimplemented-ptest", "%s: autotools-based tests detected" % d.getVar('PN'), d)
+ # Last resort, detect a test directory in sources
+ elif any(filename.lower() in ["test", "tests"] for filename in os.listdir(srcdir)):
+ oe.qa.handle_error("unimplemented-ptest", "%s: test subdirectory detected" % d.getVar('PN'), d)
+
oe.qa.exit_if_errors(d)
}