summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Kubizňák <kubiznak@2n.com>2023-01-04 12:45:55 +0100
committerSteve Sakoman <steve@sakoman.com>2023-01-19 12:21:34 -1000
commitb342790a37c891cf83f24d4f96060e2d0bd79c07 (patch)
tree2d0d6953382b28895e449eb78d107b0450c33cc9
parentdafd8cf38d6414ca3102695b5a55a8fd2718e584 (diff)
downloadopenembedded-core-contrib-b342790a37c891cf83f24d4f96060e2d0bd79c07.tar.gz
harfbuzz: remove bindir only if it exists
In some scenarios (e.g. when "glib" removed from PACKAGECONFIG), "${D}${bindir}" might not exist which caused `rmdir` to fail. Signed-off-by: Petr Kubizňák <kubiznak@2n.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 21261072cbe0056e85550a0710de142fab8943e4) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb
index b639c276db..bdbb322e42 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb
@@ -35,9 +35,9 @@ PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
LEAD_SONAME = "libharfbuzz.so"
do_install:append() {
- # If no tools are installed due to PACKAGECONFIG then this directory is
- #still installed, so remove it to stop packaging wanings.
- rmdir --ignore-fail-on-non-empty ${D}${bindir}
+ # If no tools are installed due to PACKAGECONFIG then this directory might
+ # still be installed, so remove it to stop packaging warnings.
+ [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir}
}
FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"