summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-19 15:18:16 -0800
committerSteve Sakoman <steve@sakoman.com>2023-02-01 04:16:52 -1000
commitf8dba1173dc42dd72c231fc291b2f7b44d828905 (patch)
treeae5e3d2be6e23a3e02511f4f58741759dbd5e702
parent218cf38bd3879df009e70f516c0dcb484376bf2e (diff)
downloadopenembedded-core-contrib-f8dba1173dc42dd72c231fc291b2f7b44d828905.tar.gz
libtirpc: Check if file exists before operating on it
In some cases (e.g. mingw) this file may not be installed Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 547f3a13ee9268bbdd439c96108ba1fe9ab78873) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
index 66bc4ecdd1..6980135a92 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
@@ -21,7 +21,7 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--disable-gssapi"
do_install:append() {
- chown root:root ${D}${sysconfdir}/netconfig
+ test -e ${D}${sysconfdir}/netconfig && chown root:root ${D}${sysconfdir}/netconfig
}
BBCLASSEXTEND = "native nativesdk"