summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-01-09 23:27:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-11 10:50:22 +0000
commit208021f7212a8a790c350ccca720695c5bcbb1ca (patch)
treeb3b1b7a403575fc718b4ef726a114d2a3f7933d0
parentafa2e6c31a79f75ff4113d53f618bbb349cd6c17 (diff)
downloadopenembedded-core-contrib-208021f7212a8a790c350ccca720695c5bcbb1ca.tar.gz
ruby: disable rdoc due to non-reproducibility
The issue is reported upstream: https://bugs.ruby-lang.org/issues/18456 Otherwise I do not feel that further investigation of rdoc's parser to find out the source of non-determinism is worth the time. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/lib/oeqa/selftest/cases/reproducible.py3
-rw-r--r--meta/recipes-devtools/ruby/ruby_3.0.3.bb3
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/lib/oeqa/selftest/cases/reproducible.py b/meta/lib/oeqa/selftest/cases/reproducible.py
index 35ad0009a8..a0dc76977f 100644
--- a/meta/lib/oeqa/selftest/cases/reproducible.py
+++ b/meta/lib/oeqa/selftest/cases/reproducible.py
@@ -17,12 +17,9 @@ import stat
import os
import datetime
-# ruby-ri-docs, meson:
-#https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20210215-0_td9la2/packages/diff-html/
# rust-llvm:
#https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20210825-kaihham6/
exclude_packages = [
- 'ruby-ri-docs',
'rust-llvm-liblto',
'rust-llvm-staticdev'
]
diff --git a/meta/recipes-devtools/ruby/ruby_3.0.3.bb b/meta/recipes-devtools/ruby/ruby_3.0.3.bb
index 95feb94dd4..5cf0625101 100644
--- a/meta/recipes-devtools/ruby/ruby_3.0.3.bb
+++ b/meta/recipes-devtools/ruby/ruby_3.0.3.bb
@@ -21,6 +21,9 @@ PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp"
PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
+# rdoc is off by default due to non-reproducibility reported in
+# https://bugs.ruby-lang.org/issues/18456
+PACKAGECONFIG[rdoc] = "--enable-install-rdoc,--disable-install-rdoc,"
EXTRA_OECONF = "\
--disable-versioned-paths \