summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-23 22:38:53 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-25 12:35:37 +0100
commit7012aefb10a4101b2f3baf4dc20c64e3260b4cc8 (patch)
treee68ab6b2ad4f90deaee39261b84e9a17370ef377
parent93a09a05d6dde3542587735df0aa2371e79a3bb7 (diff)
downloadopenembedded-core-contrib-7012aefb10a4101b2f3baf4dc20c64e3260b4cc8.tar.gz
llvm,mesa: Drop MESA_LLVM_RELEASE
This was needed to use provide different llvm from meta-clang or other layers, seems unused since meta-clang has stopped providing a versioned llvm Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb2
-rw-r--r--meta/recipes-graphics/mesa/mesa.inc5
2 files changed, 1 insertions, 6 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 71bc1a022a..a49965668f 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -14,8 +14,6 @@ RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
inherit cmake pkgconfig
-PROVIDES += "llvm${PV}"
-
PV = "16.0.3"
MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index 10efff96f0..439389fb8a 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -52,8 +52,6 @@ ANY_OF_DISTRO_FEATURES = "opengl vulkan"
PLATFORMS ??= "${@bb.utils.filter('PACKAGECONFIG', 'x11 wayland', d)}"
-MESA_LLVM_RELEASE ?= ""
-
# set the MESA_BUILD_TYPE to either 'release' (default) or 'debug'
# by default the upstream mesa sources build a debug release
# here we assume the user will want a release build by default
@@ -178,8 +176,7 @@ GALLIUMDRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'r600', ',r600',
GALLIUMDRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'virgl', ',virgl', '', d)}"
PACKAGECONFIG[gallium] = "-Dgallium-drivers=${@strip_comma('${GALLIUMDRIVERS}')}, -Dgallium-drivers='', libdrm"
-PACKAGECONFIG[gallium-llvm] = "-Dllvm=enabled -Dshared-llvm=enabled, -Dllvm=disabled, llvm${MESA_LLVM_RELEASE} llvm-native \
- elfutils"
+PACKAGECONFIG[gallium-llvm] = "-Dllvm=enabled -Dshared-llvm=enabled, -Dllvm=disabled, llvm llvm-native elfutils"
PACKAGECONFIG[xa] = "-Dgallium-xa=enabled, -Dgallium-xa=disabled"
PACKAGECONFIG[va] = "-Dgallium-va=enabled,-Dgallium-va=disabled,libva-initial"