summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-05-17 10:06:32 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-22 10:53:44 +0100
commitaa8001e9bff9f9dd92a4a1ce435f1ae452e104c9 (patch)
tree841ca7ebab9f116cc71522b4fe0967fa3f170238
parentee64269ffe45a54b0ec2385bac5997b9b294c2c3 (diff)
downloadopenembedded-core-contrib-aa8001e9bff9f9dd92a4a1ce435f1ae452e104c9.tar.gz
python3-setuptools-rust: fix RDEPENDS and allow target build
Cargo and rustc can now be built for the target architecture. There's no reason to limit the setuptools rust extensions to native build only so make the RDEPENDS global. Also: add the missing ones. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb b/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
index 502967fd20..01e29cc6d8 100644
--- a/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
+++ b/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
@@ -18,13 +18,16 @@ inherit cargo pypi python_setuptools_build_meta
DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
-RDEPENDS:${PN}:class-native += " \
- python3-semantic-version-native \
- python3-setuptools-native \
- python3-setuptools-scm-native \
- python3-toml-native \
- python3-typing-extensions-native \
- python3-wheel-native \
+RDEPENDS:${PN} += " \
+ python3-distutils \
+ python3-json \
+ python3-semantic-version \
+ python3-setuptools \
+ python3-setuptools-scm \
+ python3-shell \
+ python3-toml \
+ python3-typing-extensions \
+ python3-wheel \
"
BBCLASSEXTEND = "native"