summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-05-24 09:53:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-25 12:35:37 +0100
commitee37d9f05c047e1dd68e0cb47b809240d2f33835 (patch)
tree8ffc011b7b5f56c01b30a3a6d06da0635c87bd51
parent5b677b766280b39e8bf507d5aec4f08e49fd72a9 (diff)
downloadopenembedded-core-contrib-ee37d9f05c047e1dd68e0cb47b809240d2f33835.tar.gz
libx11: remove unused patch and FILESEXTRAPATHS
* 0001-fix-a-memory-leak-in-XRegisterIMInstantiateCallback.patch was removed from SRC_URI in: https://git.openembedded.org/openembedded-core/commit/?id=e13f651f73db0f26f4645447ab5fa17e36d1903b Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11/0001-fix-a-memory-leak-in-XRegisterIMInstantiateCallback.patch57
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11_1.8.4.bb6
2 files changed, 2 insertions, 61 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11/0001-fix-a-memory-leak-in-XRegisterIMInstantiateCallback.patch b/meta/recipes-graphics/xorg-lib/libx11/0001-fix-a-memory-leak-in-XRegisterIMInstantiateCallback.patch
deleted file mode 100644
index 722116c07e..0000000000
--- a/meta/recipes-graphics/xorg-lib/libx11/0001-fix-a-memory-leak-in-XRegisterIMInstantiateCallback.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-CVE: CVE-2022-3554
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@arm.com>
-
-From 1d11822601fd24a396b354fa616b04ed3df8b4ef Mon Sep 17 00:00:00 2001
-From: "Thomas E. Dickey" <dickey@invisible-island.net>
-Date: Tue, 4 Oct 2022 18:26:17 -0400
-Subject: [PATCH] fix a memory leak in XRegisterIMInstantiateCallback
-
-Analysis:
-
- _XimRegisterIMInstantiateCallback() opens an XIM and closes it using
- the internal function pointers, but the internal close function does
- not free the pointer to the XIM (this would be done in XCloseIM()).
-
-Report/patch:
-
- Date: Mon, 03 Oct 2022 18:47:32 +0800
- From: Po Lu <luangruo@yahoo.com>
- To: xorg-devel@lists.x.org
- Subject: Re: Yet another leak in Xlib
-
- For reference, here's how I'm calling XRegisterIMInstantiateCallback:
-
- XSetLocaleModifiers ("");
- XRegisterIMInstantiateCallback (compositor.display,
- XrmGetDatabase (compositor.display),
- (char *) compositor.resource_name,
- (char *) compositor.app_name,
- IMInstantiateCallback, NULL);
-
- and XMODIFIERS is:
-
- @im=ibus
-
-Signed-off-by: Thomas E. Dickey <dickey@invisible-island.net>
----
- modules/im/ximcp/imInsClbk.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/modules/im/ximcp/imInsClbk.c b/modules/im/ximcp/imInsClbk.c
-index 95b379cb..c10e347f 100644
---- a/modules/im/ximcp/imInsClbk.c
-+++ b/modules/im/ximcp/imInsClbk.c
-@@ -212,6 +212,9 @@ _XimRegisterIMInstantiateCallback(
- if( xim ) {
- lock = True;
- xim->methods->close( (XIM)xim );
-+ /* XIMs must be freed manually after being opened; close just
-+ does the protocol to deinitialize the IM. */
-+ XFree( xim );
- lock = False;
- icb->call = True;
- callback( display, client_data, NULL );
---
-2.34.1
-
diff --git a/meta/recipes-graphics/xorg-lib/libx11_1.8.4.bb b/meta/recipes-graphics/xorg-lib/libx11_1.8.4.bb
index 7831b4986a..9058c1844e 100644
--- a/meta/recipes-graphics/xorg-lib/libx11_1.8.4.bb
+++ b/meta/recipes-graphics/xorg-lib/libx11_1.8.4.bb
@@ -18,14 +18,12 @@ DEPENDS += "xorgproto \
PROVIDES = "virtual/libx11"
-FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:"
-
PE = "1"
XORG_PN = "libX11"
-SRC_URI += "file://disable_tests.patch \
- "
+SRC_URI += "file://disable_tests.patch"
+
SRC_URI[sha256sum] = "c9a287a5aefa9804ce3cfafcf516fe96ed3f7e8e45c0e2ee59e84c86757df518"
inherit gettext