aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-05-13 10:06:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-16 15:21:44 +0100
commitf422f928adc25b17966fe5bfb84bfe9dadb64555 (patch)
treed7c39eb8f5f1c5b5c433baa0d33704899d186c60
parentcd2d9a0a7420b525b518bdf35c256508db1591ed (diff)
downloadopenembedded-core-contrib-f422f928adc25b17966fe5bfb84bfe9dadb64555.tar.gz
foomatic-filters: add a link to pass LSB printing test
LSB printing test will test a foomatic-rip under cups' directory, so add it as link when DISTRO is set to linuxstdbase. Part fixes [Yocto 904] Signed-off-by: Kang Kai <kai.kang@windriver.com>
-rw-r--r--meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb b/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb
index 8d704008f7..9627187569 100644
--- a/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb
+++ b/meta/recipes-extended/foomatic/foomatic-filters_4.0.7.bb
@@ -10,7 +10,7 @@ format using a printer-specific, but spooler-independent PPD file. \
"
DEPENDS += "cups perl libxml2"
-PR = "r0"
+PR = "r1"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
@@ -20,4 +20,11 @@ SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.
SRC_URI[md5sum] = "20abd25c1c98b2dae68709062a132a7d"
SRC_URI[sha256sum] = "090313fae40b177f505d9c9b93d7a4d7188b6d5d18b6ae41ab24903ac983478d"
+do_install_append_linuxstdbase() {
+ install -d ${D}${libdir}/cups/filter
+ ln -sf ${bindir}/foomatic-rip ${D}${libdir}/cups/filter
+}
+
+FILES_${PN}_append_linuxstdbase += "${libdir}/cups/filter/foomatic-rip"
+
inherit autotools