aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-17 23:37:22 -0700
committerKhem Raj <raj.khem@gmail.com>2012-10-06 11:16:31 -0700
commitc2a3223e228137030569e3930ea9959b146780c3 (patch)
tree7d62fe84883f6e512002f3f9c258f64ec6ddb872
parent2dff670c3cc57258c0b2295270fb6f9ed26f96df (diff)
downloadopenembedded-core-contrib-c2a3223e228137030569e3930ea9959b146780c3.tar.gz
patchelf: New recipe
Add recipe for patchelf so we can build it for target and nativesdk as well. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-devtools/patchelf/patchelf_0.6.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/patchelf/patchelf_0.6.bb b/meta/recipes-devtools/patchelf/patchelf_0.6.bb
new file mode 100644
index 0000000000..62a465f65d
--- /dev/null
+++ b/meta/recipes-devtools/patchelf/patchelf_0.6.bb
@@ -0,0 +1,20 @@
+# Copyright (C) 2010 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "PatchELF is a small utility to modify the dynamic linker and RPATH of ELF executables."
+HOMEPAGE = "http://nixos.org/patchelf.html"
+LICENSE = "GPL-3.0"
+SECTION = "devel"
+PROVIDES += "chrpath"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRCREV = "a1ddbd47d3836a5912a05439f4321db0e329fbbf"
+
+SRC_URI = "http://hydra.nixos.org/build/1524660/download/2/patchelf-${PV}.tar.bz2"
+SRC_URI[md5sum] = "5087261514b4b5814a39c3d3a36eb6ef"
+SRC_URI[sha256sum] = "fc7e7fa95f282fc37a591a802629e0e1ed07bc2a8bf162228d9a69dd76127c01"
+
+inherit autotools
+
+BBCLASSEXTEND = "native nativesdk"