aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Lehtonen <markus.lehtonen@linux.intel.com>2016-11-16 16:29:24 +0200
committerMarkus Lehtonen <markus.lehtonen@linux.intel.com>2017-05-17 10:10:47 +0300
commit3941ab3c4978ba7a3a4e2c56515f0bdec09f6002 (patch)
treebf6dd88a37f4fc011fba50d56c41e04feb6bb554
parent0a35755ad753e4e0f5228d1ef747448d1ddb6e7c (diff)
downloadopenembedded-core-contrib-3941ab3c4978ba7a3a4e2c56515f0bdec09f6002.tar.gz
python-pgo-image: exclude tests from the python3 profile target
Exlude failing tests (on qemux86 target) which would cause the profile task to fail. Also, disable some very long running tests. Running in qemux86 target on my i7-3770K: test_lib2to3: 1604.5s test_buffer: 1562.8s test_pickle: 1527.0s test_io: 1517.8s test_threading: 1384.1s test_asyncio: 1380.9s test_urllib2_localnet: 1276.8s test_itertools: 944.7s test_tuple: 847.7s test_trace: 756.7s test_tarfile: 716.7s test_unicodedata: 709.9s test_decimal: 615.1s test_buffer: 1562.8s test_pickle: 1527.0s test_io: 1517.8s test_threading: 1384.1s test_asyncio: 1380.9s test_urllib2_localnet: 1276.8s test_itertools: 944.7s test_tuple: 847.7s test_trace: 756.7s test_tarfile: 716.7s test_unicodedata: 709.9s test_decimal: 615.1s [YOCTO #9338] Signed-off-by: Markus Lehtonen <markus.lehtonen@linux.intel.com>
-rw-r--r--meta/recipes-devtools/images/python-pgo-image.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/images/python-pgo-image.bb b/meta/recipes-devtools/images/python-pgo-image.bb
index 285e403d32..e16cd52486 100644
--- a/meta/recipes-devtools/images/python-pgo-image.bb
+++ b/meta/recipes-devtools/images/python-pgo-image.bb
@@ -23,6 +23,11 @@ PYTHON_PROFILE_TASK ?= "${PYTHON_PROFILE_TASK_DEFAULT}"
PYTHON3_PROFILE_DIR ?= "${TMPDIR}/work-shared/${MACHINE}/python3/pgo-data"
PYTHON3_PROFILE_TASK_DEFAULT = "-m test.regrtest --pgo -w -x test_asyncore test_gdb test_multiprocessing_fork test_multiprocessing_forkserver test_multiprocessing_main_handling test_multiprocessing_spawn test_subprocess"
+# Exclude tests that are failing on qemux86
+PYTHON3_PROFILE_TASK_DEFAULT += "test_builtin test_cmath test_concurrent_futures test_difflib test_distutils test_float test_format test_math test_optparse test_shutil test_statistics test_types test_unicode"
+# Exclude tests that are taking very long on qemux86
+PYTHON3_PROFILE_TASK_DEFAULT += "test_lib2to3 test_buffer test_pickle test_io test_threading test_asyncio test_urllib2_localnet test_itertools test_tuple test_trace test_tarfile test_unicodedata test_decimal"
+PYTHON3_PROFILE_TASK_DEFAULT += "test_long test_zipfile test_deque test_descr test_email test_venv test_bytes test_compileall test_ast test_multibytecodec"
PYTHON3_PROFILE_TASK ?= "${PYTHON3_PROFILE_TASK_DEFAULT}"