aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2014-10-27 20:43:15 +0100
committerAndreas Oberritter <obi@opendreambox.org>2015-02-23 17:15:53 +0100
commit78a3af315bde7486dd8283872952463b83ab540e (patch)
tree07dc1dd8a73c3ef17fbc9ec2a78c7c75325e6383
parentec51de464e32ecf97336ae88985140ce36cf30cd (diff)
downloadopenembedded-core-contrib-78a3af315bde7486dd8283872952463b83ab540e.tar.gz
ca-certificates: clean up before do_compile()
Otherwise the script which converts mozilla certificates extracts each certificate twice. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-support/ca-certificates/ca-certificates_20140325.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20140325.bb b/meta/recipes-support/ca-certificates/ca-certificates_20140325.bb
index a277036cfb..2e79795b7c 100644
--- a/meta/recipes-support/ca-certificates/ca-certificates_20140325.bb
+++ b/meta/recipes-support/ca-certificates/ca-certificates_20140325.bb
@@ -31,6 +31,10 @@ EXTRA_OEMAKE = "\
'SBINDIR=${sbindir}' \
"
+do_compile_prepend() {
+ oe_runmake clean
+}
+
do_install () {
install -d ${D}${datadir}/ca-certificates \
${D}${sysconfdir}/ssl/certs \