aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-09-05 16:59:12 -0500
committerAndreas Oberritter <obi@opendreambox.org>2017-10-17 04:38:27 +0200
commitac94f7c86d0db5dc60d09aa440bfdc47cd9452c5 (patch)
treeaa57334d56c01e61d8c6a2136f5a8bad98afe384
parentbf2da6672e26f2e325bb36fe942f3eeec90be1d3 (diff)
downloadopenembedded-core-contrib-ac94f7c86d0db5dc60d09aa440bfdc47cd9452c5.tar.gz
systemd_230.bb: Set journal RuntimeMaxSize to 64M as default
At this time systemd journald uses the /run tmpfs to store logs by default systemd uses 15% of available space [1] of the /run partition, when the space runs out journald starts to vaccum/store the logs into /var/log [1]. It causes two problems one of them is timeout dev-ttySN.device's when enable debug and use journal as systemd.log_target [2] the other is related to don't find syslog entries into the journal log [3]. This problems are now more evident because i recently enabled the systemd debug option in testimage [4]. One area of improvement will be add support in systemd journald to read these parameters from the kernel cmdline like systemd.log_target, if the support exists we could add that parameter at level of testimage. [1] https://www.freedesktop.org/software/systemd/man/journald.conf.html#SystemMaxUse= [2] https://bugzilla.yoctoproject.org/show_bug.cgi?id=8142#c19 [3] https://bugzilla.yoctoproject.org/show_bug.cgi?id=10128#c4 [4] http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=a86a1b2703372c12e7fca18918695d093ea6ee53 [YOCTO #10128] Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 808952bf6d2b7549b456293ead4728b4dbf0d89b) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-core/systemd/systemd_230.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_230.bb b/meta/recipes-core/systemd/systemd_230.bb
index 4d367944c7..0a244f353c 100644
--- a/meta/recipes-core/systemd/systemd_230.bb
+++ b/meta/recipes-core/systemd/systemd_230.bb
@@ -233,6 +233,9 @@ do_install() {
# Enable journal to forward message to syslog daemon
sed -i -e 's/.*ForwardToSyslog.*/ForwardToSyslog=yes/' ${D}${sysconfdir}/systemd/journald.conf
+ # Set the maximium size of runtime journal to 64M as default
+ sed -i -e 's/.*RuntimeMaxUse.*/RuntimeMaxUse=64M/' ${D}${sysconfdir}/systemd/journald.conf
+
# this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
# for existence else it fails
if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ]; then