aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-06-06 17:26:06 +0200
committerAndreas Oberritter <obi@opendreambox.org>2017-06-26 22:57:15 +0200
commit9a4cdb692d2716d6d793c6c0ffef974a97da5c52 (patch)
tree751da8fc5d2fa3858a9e36c49bb9d6c689d2cef5
parent5ebe2060b7326df7f61c714c1913d7d3173be3ea (diff)
downloadopenembedded-core-contrib-9a4cdb692d2716d6d793c6c0ffef974a97da5c52.tar.gz
keyutils: new recipe, used by nfs-utils
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-connectivity/nfs-utils/keyutils_1.5.9.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/keyutils_1.5.9.bb b/meta/recipes-connectivity/nfs-utils/keyutils_1.5.9.bb
new file mode 100644
index 0000000000..8430bb2345
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/keyutils_1.5.9.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Linux Key Management Utilities"
+HOMEPAGE = "https://people.redhat.com/~dhowells/keyutils/"
+LICENSE = "GPLv2+ & LGPLv2.1+"
+LICENSE_${PN} = "GPLv2+"
+LICENSE_lib${PN} = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \
+ file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f"
+
+SRC_URI = "https://people.redhat.com/~dhowells/keyutils/${BP}.tar.bz2"
+SRC_URI[md5sum] = "7f8ac985c45086b5fbcd12cecd23cf07"
+SRC_URI[sha256sum] = "4da2c5552c688b65ab14d4fd40fbdf720c8b396d8ece643e040cf6e707e083ae"
+
+EXTRA_OEMAKE = " \
+ DESTDIR=${D} \
+ ETCDIR=${sysconfdir} \
+ BINDIR=${bindir} \
+ SBINDIR=${sbindir} \
+ SHAREDIR=${datadir}/${BPN} \
+ MANDIR=${mandir} \
+ INCLUDEDIR=${includedir} \
+ LIBDIR=${base_libdir} \
+ USRLIBDIR=${libdir} \
+ BUILDFOR= \
+"
+
+do_install() {
+ oe_runmake install
+}
+
+PACKAGES =+ "lib${PN}"
+
+FILES_lib${PN} = "${base_libdir}/lib*${SOLIBS}"