aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-04-04 15:40:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-05 09:44:10 +0100
commitebfd79ae6e5954253c3bb0886d476be480b24de8 (patch)
tree239ae6f032ffe97b34e9e2047bf436bf436f4294
parent087e1204fb27e2952f16c2e4761f5993b7722732 (diff)
downloadopenembedded-core-contrib-ebfd79ae6e5954253c3bb0886d476be480b24de8.tar.gz
gpgme: fix configure if 'import distutils' causes output on stderr
There are a number of reasons that importing a module could cause output on stderr that isn't a fatal error (compatibilty problems with inputrc, or encoding warnings) so backport a patch from autoconf-archive to only check the exit code instead of asserting that stderr is empty. [ YOCTO #11231 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gpgme/gpgme/python-import.patch19
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.8.0.bb2
2 files changed, 20 insertions, 1 deletions
diff --git a/meta/recipes-support/gpgme/gpgme/python-import.patch b/meta/recipes-support/gpgme/gpgme/python-import.patch
new file mode 100644
index 0000000000..61b77a1f75
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme/python-import.patch
@@ -0,0 +1,19 @@
+Don't check for output on stderr to know if an import worked, host inputrc and
+sysroot readline can cause warnings on stderr.
+
+Upstream-Status: Backport (from autoconf-archive 883a2abd)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/m4/ax_python_devel.m4 b/m4/ax_python_devel.m4
+index b990d5b..318b089 100644
+--- a/m4/ax_python_devel.m4
++++ b/m4/ax_python_devel.m4
+@@ -137,7 +137,7 @@ variable to configure. See ``configure --help'' for reference.
+ #
+ AC_MSG_CHECKING([for the distutils Python package])
+ ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
+- if test -z "$ac_distutils_result"; then
++ if test $? -eq 0; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
diff --git a/meta/recipes-support/gpgme/gpgme_1.8.0.bb b/meta/recipes-support/gpgme/gpgme_1.8.0.bb
index 2756ef815d..eddf3a0399 100644
--- a/meta/recipes-support/gpgme/gpgme_1.8.0.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.8.0.bb
@@ -15,6 +15,7 @@ SRC_URI = "${GNUPG_MIRROR}/gpgme/${BP}.tar.bz2 \
file://python-lang-config.patch \
file://0001-Correctly-install-python-modules.patch \
file://0001-Avoid-host-contamination-from-gpg-config.patch \
+ file://python-import.patch \
"
SRC_URI[md5sum] = "722a4153904b9b5dc15485a22d29263b"
@@ -70,4 +71,3 @@ do_configure_prepend () {
rm -f ${S}/m4/gpg-error.m4
rm -f ${S}/m4/libassuan.m4
}
-