summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-06-09 22:10:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-10 16:03:17 +0100
commit51592bafececf2423747fccd183a556eaa17bcd7 (patch)
tree738166b43fdeea947d4be8a748fb830f943bebea
parent87722a92c18f94917c8f70afc8cd0763462a5c25 (diff)
downloadopenembedded-core-contrib-51592bafececf2423747fccd183a556eaa17bcd7.tar.gz
stress-ng: Fix build on musl
Define daddr_t if not provided by system headers Fixes ./stress-ng.h:3755:2: error: unknown type name 'daddr_t'; did you mean 'caddr_t'? daddr_t f_tfree; ^~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch22
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb2
2 files changed, 23 insertions, 1 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch b/meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch
new file mode 100644
index 0000000000..877f4f0624
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch
@@ -0,0 +1,22 @@
+Define daddr_t if __DADDR_T_TYPE is not defined
+
+glibc defined daddr_t but musl does not, ideally it should not be used
+and simple int type is enough. However, its better to leave glibc behavior
+as it is and only define it to int if daddr_t is not provided by libc
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/stress-ng.h
++++ b/stress-ng.h
+@@ -3750,6 +3750,10 @@ struct shim_statx {
+ uint64_t __spare2[14];
+ };
+
++#ifndef __DADDR_T_TYPE
++typedef int daddr_t;
++#endif
++
+ /* old ustat struct */
+ struct shim_ustat {
+ daddr_t f_tfree;
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb b/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
index 45f4bb41ad..c00086c095 100644
--- a/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
+ file://no_daddr_t.patch \
"
SRC_URI[sha256sum] = "0ccf437ca1876a3e8a55986c6481697045203a17f5994cb2f5096cd461d18031"
@@ -23,4 +24,3 @@ do_install() {
oe_runmake DESTDIR=${D} install
}
-COMPATIBLE_HOST_libc-musl = 'null'