aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-07-18 21:43:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:27:58 +0100
commit71dd4c05c41e8b363dc1ecac1f5105d316ee82dc (patch)
treeef89d335d9954da706d8903506599a95398e91d5
parentb36712eef14c20007e0adb01cc7d4bce9e7926bb (diff)
downloadopenembedded-core-contrib-71dd4c05c41e8b363dc1ecac1f5105d316ee82dc.tar.gz
oeqa/recipetool: update recipe test to pass SHA
Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/lib/oeqa/selftest/recipetool.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/lib/oeqa/selftest/recipetool.py b/meta/lib/oeqa/selftest/recipetool.py
index 2e38758aec..f8f6be32a4 100644
--- a/meta/lib/oeqa/selftest/recipetool.py
+++ b/meta/lib/oeqa/selftest/recipetool.py
@@ -389,7 +389,7 @@ class RecipetoolTests(RecipetoolBase):
os.makedirs(tempsrc)
recipefile = os.path.join(self.tempdir, 'libmatchbox.bb')
srcuri = 'git://git.yoctoproject.org/libmatchbox'
- result = runCmd('recipetool create -o %s %s -x %s' % (recipefile, srcuri, tempsrc))
+ result = runCmd(['recipetool', 'create', '-o', recipefile, srcuri + ";rev=9f7cf8895ae2d39c465c04cc78e918c157420269", '-x', tempsrc])
self.assertTrue(os.path.isfile(recipefile), 'recipetool did not create recipe file; output:\n%s' % result.output)
checkvars = {}
checkvars['LICENSE'] = 'LGPLv2.1'