aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-05-18 13:40:39 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-21 22:21:29 +0100
commitb9a484b05e1901c5f612d23a006ee6f887ee2f17 (patch)
tree8881f3635e62fd14e1a64176ddf56118061bbed5
parenta3084bd681f67b28b4e4b44ba0c6a281800f719d (diff)
downloadopenembedded-core-contrib-b9a484b05e1901c5f612d23a006ee6f887ee2f17.tar.gz
weston: Enable XWayland when X11 and Wayland support are available
When the DISTRO has X11 and Wayland support enabled, XWayland ought to be enabled by default. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/wayland/weston_1.10.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.10.0.bb b/meta/recipes-graphics/wayland/weston_1.10.0.bb
index 16e961de3f..98a5fbadec 100644
--- a/meta/recipes-graphics/wayland/weston_1.10.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.10.0.bb
@@ -38,6 +38,7 @@ EXTRA_OECONF_append_qemux86-64 = "\
"
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
clients"
@@ -91,11 +92,15 @@ do_install_append() {
fi
}
+PACKAGE_BEFORE_PN += "${PN}-xwayland"
PACKAGES += "${PN}-examples"
FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}"
FILES_${PN}-examples = "${bindir}/*"
+FILES_${PN}-xwayland = "${libdir}/${BPN}/xwayland.so"
+RDEPENDS_${PN}-xwayland += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'xserver-xorg-xwayland', '', d)}"
+
RDEPENDS_${PN} += "xkeyboard-config"
RRECOMMENDS_${PN} = "liberation-fonts"
RRECOMMENDS_${PN}-dev += "wayland-protocols"