aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-04-11 00:29:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-11 22:01:54 +0100
commit36eb5b6e75361053b5dd00652df6361499d8a645 (patch)
tree23ac5a170a2c39e883974c8ec89e98718e3467d4
parent2ba9f90e86d25aa0b9319093478ea2218e1423e4 (diff)
downloadopenembedded-core-contrib-36eb5b6e75361053b5dd00652df6361499d8a645.tar.gz
systemd: chown hwdb.bin to root:root for do_rootfs
This is created by qemu for the do_rootfs case, which bypasses pseudo, so we need to correct the ownership. This fixes a warning issued by rootfs_check_host_user_contaminated. (From OE-Core master rev: 4ff6b8cadec10e17dbf884a873a227e29944f5d1) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_225.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_225.bb b/meta/recipes-core/systemd/systemd_225.bb
index 7c66ba20e4..9346260b57 100644
--- a/meta/recipes-core/systemd/systemd_225.bb
+++ b/meta/recipes-core/systemd/systemd_225.bb
@@ -402,6 +402,7 @@ pkg_postinst_udev-hwdb () {
if test -n "$D"; then
${@qemu_run_binary(d, '$D', '${base_bindir}/udevadm')} hwdb --update \
--root $D
+ chown root:root $D${sysconfdir}/udev/hwdb.bin
else
udevadm hwdb --update
fi