summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Mitchell <ml@embed.me.uk>2020-12-03 10:35:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-06 23:16:50 +0000
commitea5e65b578498df7976bbc560bdcd39c2ebcc1d9 (patch)
tree57f13477a95893eb359e5611bf25eb118b428679
parent99d55bd094fe3d12724d77af3f15e2494cad4e0d (diff)
downloadopenembedded-core-contrib-ea5e65b578498df7976bbc560bdcd39c2ebcc1d9.tar.gz
systemd-conf: add PACKAGECONFIG to enable/disable auto ethernet DHCP
Allow distros which include other network managers to disable the auto DHCP setup of interfaces in systemd-networkd. Signed-off-by: Jack Mitchell <ml@embed.me.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd-conf_246.1.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-conf_246.1.bb b/meta/recipes-core/systemd/systemd-conf_246.1.bb
index d9ec023bfd..944b56ff82 100644
--- a/meta/recipes-core/systemd/systemd-conf_246.1.bb
+++ b/meta/recipes-core/systemd/systemd-conf_246.1.bb
@@ -5,6 +5,9 @@ DefaultTimeoutStartSec setting."
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PACKAGECONFIG ??= "dhcp-ethernet"
+PACKAGECONFIG[dhcp-ethernet] = ""
+
SRC_URI = "\
file://journald.conf \
file://logind.conf \
@@ -17,7 +20,10 @@ do_install() {
install -D -m0644 ${WORKDIR}/journald.conf ${D}${systemd_unitdir}/journald.conf.d/00-${PN}.conf
install -D -m0644 ${WORKDIR}/logind.conf ${D}${systemd_unitdir}/logind.conf.d/00-${PN}.conf
install -D -m0644 ${WORKDIR}/system.conf ${D}${systemd_unitdir}/system.conf.d/00-${PN}.conf
- install -D -m0644 ${WORKDIR}/wired.network ${D}${systemd_unitdir}/network/80-wired.network
+
+ if ${@bb.utils.contains('PACKAGECONFIG', 'dhcp-ethernet', 'true', 'false', d)}; then
+ install -D -m0644 ${WORKDIR}/wired.network ${D}${systemd_unitdir}/network/80-wired.network
+ fi
}
# Based on change from YP bug 8141, OE commit 5196d7bacaef1076c361adaa2867be31759c1b52