summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-22 11:16:45 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-25 15:06:46 +0000
commit0d9bc65139a9cabbeabe166e83f2d61f47d7bdd7 (patch)
treec6acbcd8c9fcab98665acb4978b7f293d78b8b9d
parent2fc5674487be59bfdda21f7646c53d90687f1c36 (diff)
downloadopenembedded-core-contrib-0d9bc65139a9cabbeabe166e83f2d61f47d7bdd7.tar.gz
meson: inherit setuptools_build_meta
Upstream provides a pyproject.toml which declares setuptools.build_meta to be backend for PEP-517 packaging. Set PIP_INSTALL_PACKAGE as this recipe does not inherit pypi and therefor no PYPI_PACKAGE is defined [YOCTO #14638] Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/meson/meson_0.61.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/meson/meson_0.61.2.bb b/meta/recipes-devtools/meson/meson_0.61.2.bb
index 45938af6ff..a51db1e3d4 100644
--- a/meta/recipes-devtools/meson/meson_0.61.2.bb
+++ b/meta/recipes-devtools/meson/meson_0.61.2.bb
@@ -21,7 +21,9 @@ SRC_URI[sha256sum] = "0233a7f8d959079318f6052b0939c27f68a5de86ba601f25c9ee6869fb
UPSTREAM_CHECK_URI = "https://github.com/mesonbuild/meson/releases"
UPSTREAM_CHECK_REGEX = "meson-(?P<pver>\d+(\.\d+)+)\.tar"
-inherit setuptools3
+inherit setuptools_build_meta
+
+PIP_INSTALL_PACKAGE = "meson"
RDEPENDS:${PN} = "ninja python3-modules python3-pkg-resources"