aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-26 22:49:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-27 18:03:44 +0000
commite6f1d15e307a8d2f5f05c9ec9dd8163e9072ad07 (patch)
tree1b022bb7b3d00148b0db8c605434bdcdd98fff36
parent084f4de4dbaf9821516fc0254d35f4fb04311d27 (diff)
downloadopenembedded-core-contrib-e6f1d15e307a8d2f5f05c9ec9dd8163e9072ad07.tar.gz
lttng-tools: Disable hanging tests and other ptest fixes
Disable some tests which hang, blocking many other ptests. Also add missing test artefacts to improve test pass rate and fix failures. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb b/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
index 13bab9068e..9d21fb00bf 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
@@ -63,11 +63,11 @@ do_install_append () {
}
do_install_ptest () {
- for f in Makefile tests/Makefile tests/utils/utils.sh ; do
+ for f in Makefile tests/Makefile tests/utils/utils.sh tests/regression/tools/save-load/load-42*.lttng tests/regression/tools/save-load/configuration/load-42*.lttng ; do
install -D "${B}/$f" "${D}${PTEST_PATH}/$f"
done
- for f in config/tap-driver.sh config/test-driver ; do
+ for f in config/tap-driver.sh config/test-driver src/common/config/session.xsd src/common/mi-lttng-3.0.xsd; do
install -D "${S}/$f" "${D}${PTEST_PATH}/$f"
done
@@ -141,8 +141,17 @@ do_install_ptest () {
-e 's#\(^test.*LDADD.=\)#disable\1#g' \
-i ${D}${PTEST_PATH}/tests/unit/Makefile
+ #
+ # Disable notification tools tests as currently
+ # these hang and cause the rest of the ptests to timeout
+ #
+ sed -e 's#tools/notification/test_notification_ust##g' \
+ -e 's#tools/notification/test_notification_kernel##g' \
+ -e 's#tools/notification/test_notification_multi_app##g' \
+ -i ${D}${PTEST_PATH}/tests/regression/Makefile
+
# Substitute links to installed binaries.
- for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd ; do
+ for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd lttng-crash; do
exedir="${D}${PTEST_PATH}/src/bin/${prog}"
install -d "$exedir"
case "$prog" in