aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-01-21 09:48:24 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-21 23:46:46 +0000
commitad6a8fae67acd291b9d7f554ae1a8c621b51fded (patch)
tree87a9eb2b4b727dfdbb85ff108ff8b0b40365ee5f
parent4bd297dfe92851f3b44f6b5560bac9d8f9ccf9f2 (diff)
downloadopenembedded-core-contrib-ad6a8fae67acd291b9d7f554ae1a8c621b51fded.tar.gz
perl-native: unset configure symbol i_xlocale
perl-native checks xlocale.h on build machine. But xlocale.h has been removed by glibc already. When use share state caches between machines that one has xlocale.h but the other one doesn't, it causes packages which depend on perl-native such as libdbi-perl-native fails to compile: | In file included from DBIXS.h:23, | from Perl.xs:7: | .../tmp-glibc/work/x86_64-linux/libdbi-perl-native/1.642-r0/recipe-sysroot-native/usr/lib/perl5/5.28.1/x86_64-linux/CORE/perl.h:723:13: | fatal error: xlocale.h: No such file or directory | # include <xlocale.h> | ^~~~~~~~~~~ | compilation terminated. Unset configure symbol i_xlocale for perl-native to fix the issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
index 949758c4d4..176980e1b2 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
@@ -82,7 +82,8 @@ do_configure_class-native() {
-Dbin=${bindir}/perl-native \
-Duseshrplib \
-Dsoname=libperl.so.5 \
- -Dvendorprefix=${prefix}
+ -Dvendorprefix=${prefix} \
+ -Ui_xlocale
}
do_compile() {