summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-30 12:45:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-01 10:41:15 +0000
commit0be006cc5f6df32fbc4df8c73851a960d4081ed3 (patch)
treea92b4d009d83bb48ac35ae1e8243f9178efa375d
parenta5c5977bef44b7b014af590515ea1f93d7d51f46 (diff)
downloadopenembedded-core-contrib-0be006cc5f6df32fbc4df8c73851a960d4081ed3.tar.gz
wpebackend-fdo: Add -Wno-c++11-narrowing
This commit https://github.com/Igalia/WPEBackend-fdo/commit/e4c578f23359dba4d5abbd14b108f59e1b0701c1 causes this warning due to int to uint conversion without static casts unless its fixes properly by upstream make behaviour same as g++ where this is flagged too but only as a warning unlike clang which is pedantic and enables it as error Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/webkit/wpebackend-fdo_1.12.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/wpebackend-fdo_1.12.0.bb b/meta/recipes-sato/webkit/wpebackend-fdo_1.12.0.bb
index ba6c54412a..4a18467ea4 100644
--- a/meta/recipes-sato/webkit/wpebackend-fdo_1.12.0.bb
+++ b/meta/recipes-sato/webkit/wpebackend-fdo_1.12.0.bb
@@ -15,6 +15,10 @@ REQUIRED_DISTRO_FEATURES = "opengl"
SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "6239c9c15523410798d66315de6b491712ab30009ba180f3e0dd076d9b0074ac"
+# Especially helps compiling with clang which enable this as error when
+# using c++11
+CXXFLAGS += "-Wno-c++11-narrowing"
+
# This is a tweak of upstream-version-is-even needed because
# ipstream directory contains tarballs for other components as well.
UPSTREAM_CHECK_REGEX = "wpebackend-fdo-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"